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VEST, Inc. 

HyDraw® CAD 2019 Software License & Services Agreement 

Carefully read the terms and conditions of this Agreement before 
proceeding further. Using this software indicates your acceptance 
of these terms and conditions. 

License 

VEST, Incorporated (“we, our, us”) grants the Licensee (“you, 
your”) a non-transferable and non-exclusive license to use the 
software product in the specified quantity only, subject to and 
conditioned on Licensee’s continuous compliance with this 
Agreement and payment of the applicable fees. 

You may not:  

1. Distribute, sublicense or copy any portion of the licensed 
software product 

2. Modify or prepare derivative works from the licensed 
software product 

3. Use the licensed software product in multiple computers or 
multiple user arrangements unless that use is covered by an 
individual license for each computer or user. 

You agree that the licensed software product belongs to us and 
you agree to keep confidential and use your best efforts to 
prevent and protect the contents of the licensed software product 
from unauthorized disclosure. 

Limited Warranty  

VEST, Inc. warrants that, as of the date on which the Software 
Products are delivered and licensed to Licensee and for ninety 
(90) days thereafter, the (“Warranty Period”), the Software 
Products will provide the general features and functions described 
in the User Documentation of the Software Product.  VEST’s entire 
liability and Licensee’s exclusive remedy during the Warranty 
Period (“Limited Warranty”) will be, (i) to attempt to correct or 
work around errors, if any, or (ii) to refund the Software fees, if 
any, paid by Licensee.  Such refund is subject to the return, of the 
Software License by the Licensee, if the license has already been 
issued. This warranty does not cover damage caused by virus, 
improper use or neglect.  

 The Software product is furnished "AS IS" and without warranty as 
to the performance or results you may obtain by using the 
licensed software product or that it will be error free. You assume 
the entire risk as to the results and performance of the licensed 
software product. To get warranty service during the 90-day 
Warranty Period, you may return the product license to VEST, 
Inc., with a description of the problem.  

Limitations of Liability 

YOU UNDERSTAND AND AGREE AS FOLLOWS: 

A.  Warranties in this Agreement replace all other warranties, 
express or implied, including any warranties of merchantability or 
fitness for a particular purpose. We disclaim and exclude all other 
warranties. 

B.  We will not be liable for any loss or damage caused by delay in 
furnishing a licensed software product or any other performance 
under this Agreement.   

C.  Our entire liability and your exclusive remedies for our liability 
of any kind (including liability for negligence) for the licensed 
software product covered by the agreement and all other 
performance or non-performance by us under or related to this 
Agreement are limited to the remedies specified by this 
Agreement. 

D.  In no event will our liability of any kind include any special 
incidental or consequential damages, for loss of profits, use, 
revenue or data; or for business interruption (regardless of the 
legal theory for seeking such damages or other liability. In 
addition, the liability of VEST, Inc., and its partners, arising out of 
or relating to any VEST, Inc. software or service will not exceed 
the amount paid or payable by Licensee for such software or 
services. 

E.  Subscribers to manufacturer and other data services related to 
our Software hereby acknowledge and agree that the services are 
provided by VEST, Inc. on an ‘As Is’ basis, and the Subscriber’s 
access and use of the service is at its sole risk.  VEST, Inc. and the 
manufacturers expressly disclaim all warranties of any kind, 
whether express or implied, including any damages that may 
result from the use of this service 

 VEST Inc. makes no warranty that the services will meet the 
requirements of the Subscriber, or that the services will be 
uninterrupted, or error-free, nor does VEST Inc. make any 
warranty as to the results that may be obtained through the use 
of the services.  Subscriber understands and agrees that any data 
downloaded through the use of the service is done at the sole risk 
of the Subscriber and the Subscriber will be solely responsible for 
any damage which might result from use of this data. 

F.  Special notice to consumers: some states do not allow the 
exclusion of implied warranties, so the above exclusion may not 
apply to you. The warranty gives you special legal rights, and you 
may also have other rights, which vary from state to state. 

Termination 

This Agreement is effective until terminated. You may terminate it 
any time by returning the licensed software product. It will also 
terminate if you do not comply with any term or condition of this 
agreement. VEST, Inc. may, as an alternative to termination, 
suspend Licensee’s license if the Licensee fails to make payment 
to VEST, Inc. or its Distributor, or otherwise fails to comply with 
the provisions of this Agreement. 

General   

You are responsible for installation, management and operation 
of the licensed software product. 

 

© 2002-2018, VEST, Inc.  All rights reserved. 
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1. Introduction 

Welcome to VEST HyDraw® CAD 2019 

Create accurate, error free, professionally drawn 
hydraulic circuits, part lists, and quotations 
quickly and easily. 

Drag-and-drop ‘smart’ symbols into a drawing 
with point-and-click component selection.  
The ‘smart’ connection lines snap to ports and 
self-route with jumpers. 

Auto BOM generation ensures accuracy of your 
Bill of Materials. Easily insert it into the circuit 
drawing or export it to Microsoft Excel. 

Get started with over 8,000 ISO 1219-1 compliant 
symbols covering both industrial and mobile 
hydraulics. ‘Remember’ your data and rules using 
HyDraw custom database. Ensure up-to-date 
pricing of components by linking your ERP data to 
HyDraw. 

Circuit design data can be ported to downstream 
manifold design and CAM systems. 

HyDraw can access manufacturer component 
data from FluidPowerTools.com, a fee-based 
service from VEST. 

Use HyDraw and ensure your competitive edge. 

 
 

 
HyDraw CAD drawing area with HyDraw CAD Ribbon menu, HyDraw Library Explorer, and HyDraw Property Manager 
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HyDraw® CAD 2019 is easy to use. It works 
seamlessly with its own ribbon menu. HyDraw 
symbols are located quickly by navigating logically 
structured menus. Sets of related symbols are 
shown together and any required symbol can be 
inserted into the drawing by drag-and-drop method 
or double-click on a symbol. You can insert generic 
symbols or model code specific component symbols 
into the library. Edit parametric properties of the 
inserted symbols, when needed. 

HyDraw Library 

The HyDraw library accommodates a wide range of 
simple and complex graphical component symbols, 
and schematic diagrams covering both Industrial 
and Mobile Hydraulics. Designed in accordance 
with ISO1219-1:2012, Fluid Power Systems and 
Components - Graphic Symbols and Circuit 
Diagrams - Part 1: Graphic Symbols for 
Conventional Use and Data Processing Applications. 
A few percentile deviations from ISO standard 
necessitated keeping in view the large variants of 
symbols and customer base. The HyDraw library 
includes both Slip-in and Screw-in Cartridge valves 
and associated symbols for manifold design circuits. 

 
Smart Symbols 

HyDraw symbols are created using primitive 
shapes, such as lines, polylines, rectangles, squares, 
circles, circular arcs, ellipsis. They represent 
components with specified functions or method of 
operation in the de-energized (at rest) position, or 
component specific rule that do not have a clearly 
defined de-energized position. A pool of ISO 
specified primitive shapes are included in the 
library to help you design your own generic 
symbols. HyDraw symbols also include port 
identification and port numbering, which is 
essential for manifold design. 

ISO guidelines 

VEST has adhered to ISO guidelines of Module 
System (1Module = 2 Millimeter), where the 
symbol fits into a grid and presents a symmetry. 
The use of layer properties for assigning ISO 
defined color to Supply line, Return line, Pilot line, 
Drain line, Envelope line, and Flow direction 
exhibits appealing color graphics, which help in 
instant understanding of the operational aspect of 
the component. Layer properties are also utilized 
for naming ports, positions and solenoids. (both US 
and European pattern) 

 
Search 

Save time and effort with the new and powerful 
HyDraw CAD 2019 Search from library command. 
Search general or OEM specific symbols and circuits 
from www.FluidPowerTools.com. 

Teamwork 

HyDraw helps standardization and teamwork. 
Multiple users within a local area network can 
share a common HyDraw library. This enhances 
productivity of the design and engineering team. 

Customization 

Customize HyDraw to your specific need using the 
library and data management console. Save custom 
components data with symbols tagged to a specific 
model code and relevant OEM catalog data. 

More… 

OEM-specific circuit design with Parts List from 
component properties held in the library make the 
software very productive. 

Net List creation, Manifold Cost estimation and 
interface to FluidPowerTools.com enable significant 
cost and time-savings. 

Work Smart! Use HyDraw® today. 

http://www.fluidpowertools.com/
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2. Support 
 

Help 

The HyDraw® CAD 2019 Help provides comprehensive 
information on the features, commands, usage, processes, and 
design methodology of HyDraw. 

The Help can be used as a comprehensive reference to the 
command set and usage of HyDraw. 
 

 The Contents and Index listing guides you to relevant material 
for study and reference. 

The User Manual Adobe Acrobat file includes a left-hand 
column nested menu for easy chapter navigation.   
(Acrobat Reader: View > Navigation Panels > Bookmarks) 

 
About HyDraw CAD 

   **Click the HyDraw command on the Help ribbon menu to view the user manual in the Adobe Acrobat .pdf format. 

Support 

If you have a question about HyDraw CAD 2019 email us at 
support@VESTusa.com. 

Please include the following: 

• Version number of the software you use. 
To see the version of HyDraw on your machine, 
Click About HyDraw from the Help ribbon menu.  

• Configuration of your machine. 

• Exact messages, if any, on the screen.  
Send a screen capture, if possible. 

• Description of the problem and what you were doing 
when the problem occurred. 

• Description of how you tried to solve the problem. 

 

***Click the About HyDraw command on the Help ribbon 
menu to view the About HyDraw message box indicating 
the software version number. 

 
About HyDraw message box 

mailto:support@VESTusa.com
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Workspace 
  

 
 
 

 
 
 
 
 
 
 
 

 
 

3 HyDraw Startup 

4 HyDraw CAD Ribbon Menu 

5 HyDraw Shortcuts 

6 HyDraw Library Explorer 

7 HyDraw Property Manager 

8 HyDraw Options 
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3. HyDraw Startup 
 

Note: 

For HyDraw® CAD installation, 
 refer Ch 79. 

 

Open HyDraw CAD 2019 

➢ Double click the HyDraw CAD 
2019 desktop shortcut icon. 

 

Alternatively, 
Click Start 
  > All Apps 
      > HyDraw CAD 2019 
            > HyDraw CAD 2019 

HyDraw CAD opens with the 
Ribbon menu, Library 
Explorer and Property 
Manager. 

 
HyDraw CAD opens with Library Explorer and Property Manager 
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4. HyDraw CAD Ribbon Menu 
HyDraw® CAD has a ribbon menu with four tabs, Circuit, System, Services, and Help for ready access to the frequently used commands. 
 

 
HyDraw CAD – Circuit Ribbon menu 

 
HyDraw CAD – System Ribbon menu 

 

 
HyDraw CAD – Services Ribbon Menu 

 

 
HyDraw CAD – Help Ribbon Menu  
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5. HyDraw Shortcuts 
Shortcut command for HyDraw introduced for easy access from command line.  

 
The predefined HyDraw shortcuts or aliases: 

LICENSEINFO HyDraw CAD 2019 License Details 

YL                     Library Explorer 

YP Property Manager 

YCP Pressure Connection Line 

YCR Reservoir Connection Line 

YCS Suction Connection Line 

YCC Control Connection Line 

YCD Drain Connection Line 

YCW Working Connection Line 

YC1 Custom Connection Line1 

YC2 Custom Connection Line2 

YC3 Custom Connection Line3 

YC4 Custom Connection Line4 

YC5 Custom Connection Line5 

YE Insert Envelope 

YG Insert Gauge Port 

YM Match Connection Properties 

YR Refresh Properties 

YB Update Balloon 

YI Assign Item ID 

YPA Parts List 

YPO Ports List 

YN Net List 

YO HyDraw Options 
 

You can also, add HyDraw Ribbon Menu commands to Quick 
Access toolbar. 

 

 
Command Line HyDraw shortcuts or aliases 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Quick Access Toolbar 
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6. HyDraw Library Explorer 
The HyDraw® Library Explorer provides access to symbols, external ports, components and sub-systems. 
Locate them using either the tree view structure or the search option 

 
Symbols and external ports inserted from HyDraw Library Explorer to design schematic  
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1. Open HyDraw Library Explorer 

• Click Circuit  >  From Library Explorer from 
the Symbol option on the HyDraw® CAD 2019 
ribbon menu. 

Alternatively, 

• Click Circuit  >  Symbol   
               on the HyDraw ribbon menu. 

The HyDraw Library Explorer dockable 
window displays and docks on the left of 
the screen. 

 

2. Move HyDraw Library Explorer 

• Select HyDraw Library Explorer using the 
caption bar and  
drag or dock it to the desired location. 

HyDraw stores the information about 
the docking location of the Library 
Explorer. 

 

3. Show/Hide HyDraw Library Explorer 

• Use the automatic Show/Hide feature of the 
Library Explorer to maximize the drawing 
space.  

• Right click on the window border and  
uncheck Allow Docking. 

• Use  icon to Show/Hide the Library 
Explorer. 

 

Show/Hide HyDraw Library Explorer 
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4. Load HyDraw Library Explorer on 
Startup 

• Select Circuit >   from the HyDraw® CAD 
2019 ribbon menu. 

• Click the Misc. tab. 

• Select Library Explorer from the Load on 
startup group box. 

When subsequently opened, the Library 
Explorer docks to its previous location. 

 
HyDraw Options: Misc. 
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7. HyDraw Property Manager 
The HyDraw® Property Manager displays assigned properties of the selected items, such as symbols, ports, connection lines, envelope, sub-systems and systems. 
Search the component or model code with given inputs in the Fetch Model Data. 
Configure your own design requirements and save the data into the library. 

 
Display assigned properties of the selected symbol using the HyDraw Property Manager  
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1. Open HyDraw Property Manager 

• Click Circuit >  on the HyDraw® CAD 2019 
ribbon menu.  

The HyDraw Property Manager dockable 
window displays and docks on the right side 
of the screen. 

The HyDraw Property Manager displays two 
tabs, Selected Item and System. 

 
 

Dock HyDraw Property Manager 

• To move the Property Manager window,  
select it using the caption bar, then drag and 
dock it to the desired location.  

HyDraw stores the information about the 
docking location of the Property Manager 

 
HyDraw Property Manager 
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Selected Item tab 

The Selected Item tab page displays the properties of 
the selected component. 

The Selected Item tab page remains collapsed, if 
the item is not selected in the drawing. 

Include in Parts List option is available for 
selection, when one or many Component 
Symbols selected in the drawing. 

 
 
 
 
 
 
 
 
 
Note:  

• Deselect Exclude from Parts List to exclude the 
selected item(s) from BOM. 

• By default, the Exclude from Parts List option is 
deselected for all inserted symbols. 

• Exclude accessories separately, if required.  

         
Selected Item tab page                                             Exclude Accessories 
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System tab 

The System tab page displays properties of the 
complete circuit. 

It automatically expands all sections, whenever the 
schematic is opened in the drawing. 

When the item is selected, or the schematic is open, 
the respective menu bar expands and the assigned 
values display. 

When the item is selected in the component/external 
ports/envelopes/sub-systems, selected item displays 
in the drawing by zoom to extents selection. 

Click  to expand/collapse. 

 
System tab page 
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2. Load HyDraw Property Manager on Startup 

Select Circuit >  in the HyDraw® CAD 2019 ribbon 
menu. 

1. Click the Misc. tab. 

2. Select the Property manager checkbox from the 
Load on startup section. 

Subsequently, the Property Manager opens 
and docks at its previous location. 

 
HyDraw Options: Misc. 
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8. HyDraw Options 
Customize HyDraw® settings, such as Application, Units, Item ID, Connection, External Port, Lists & Charts, Library Path, Misc., Internet Settings, Update from Excel, Gauge Port, 
Property Display, Drawing Template and Balloon. 

1. Application 

The Application option enables you to select one of 
the three applications: Hydraulic, Pneumatic, and 
Electrical. 

1. Click the Application tab. 

The Application tab page displays. 

2. Select the required application: Hydraulic, 
Pneumatic, or Electrical. 

The HyDraw Library Explorer search from 
local database works as per selected 
applications in the HyDraw Options. 

The HyDraw Property Manager select model 
from local database and select accessories 
from library works as per selected application 
in the HyDraw Options.  

3. Click OK. 

 

Application tab page 
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2. Units 

The Units option enables you to select the unit for the 
selected application. 

1. Click the Units tab. 

The Units tab page displays. 

2. Select the required drawing units (Imperial or 
Metric). 

CAUTION! 

Units should not be changed after symbol 
insertion. 

 

3. Click Advanced Options. 

Modify Units grid displays. 

 

 
Units tab page 
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Units tab – Advanced Options 

1. Configure each unit category by selecting the 
Primary Unit. 

2. Select the Display alternate unit check box to 
display alternate unit along with the primary 
unit, if required. 

The Alternate Unit column displays. 

3. Configure the alternate units.  

4. Click Reset button to restore the default units. 

5. Click OK to apply and exit. 

 

 
Units tab – Display alternate unit 

 
Displays Dual units in the drawing 
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3. External Port 

Customize the external port in a circuit.  

1. Click the External Port tab. 

The External Port tab page displays. 

2. Click an appropriate button to configure the 
external port either circle, oval, line, rectangle, 
square shape or Custom shape.  

The respective shapes display in the port preview 
section of the HyDraw® Library Explorer window 
and can be inserted on the envelope line of the 
circuit. 

When you select the custom shape, then all the 
custom shapes present in the library will display 
in the port preview section of the HyDraw 
Library Explorer window. 

3. Select the shape in the Default symbol for 
automatic insertion on envelope drop down to 
insert automatically when an envelope 
intersects with the connection line. 

4. Click OK to apply and exit. 

 
Note: 

For adding custom shape to the HyDraw library refer 
Ch83. 

 
External Port tab page 

  



 

VEST, Inc. HyDraw® CAD 2019 21 

 

4. Lists & Charts 

Customize the Parts List format 

1. Click the Lists & Charts tab of HyDraw® options 
to select Parts list. 

2. To rename a selected format, type the new 

name in the text box and then click . 

3. To add a new format,  
type the new name in the text box and then 

click  below the textbox. 

4. To delete a selected format, click  below the 
textbox.  

5. To move up, select the item and click . 

6. To move down, select the item and click . 

7. To delete a property, click . 

You cannot delete property item ID. 

8. To add Parts list columns, click . 

The Select Parts List Columns dialog box 
displays.  

9. To include Quantity column, select the Quantity 
check box in the miscellaneous section. 

10. Select the required properties 
and click OK.  

Parts List tab page 
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The selected properties are displayed in the 
Parts List tab page- Configure columns. 

Unit: The Display with column header option 
shows the unit in the column header of the parts 
list column.  

The Display with property value option shows 
the unit with the property value of each row. 

Text: The Display in Upper Case option shows 
the list in the upper case. Also, you can change 
the text size of the list. 

Heading: The Heading drop-down option selects 
the list header direction. For example, top, 
bottom or none. 

Direction: Sort the list in an ascending or 
descending order. 

11. Select the Browse button to export the Parts list 
in the Excel template format. Select the starting 
rows and columns of the given template. 

12. Click OK. 

The selected properties are displayed in a 
tabular form when the Parts list is created in 
the drawing. 

 
Note: 

To learn more about Parts List, refer Chapter 58. 

 
Select Parts List Columns 
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Hose List 

Customize the Hose List format. 

1. Click the Lists & Charts tab of HyDraw® Options 
and select Hose List. 

The Hose List tab page displays. 

2. To rename a selected format,  
type the new name in the text box and then 

click . 

3. To add a new format,  
type the new name in the text box and then 

click  below the textbox. 

4. To delete a selected format, click  below the 
textbox.  

5. To move up, select the item and click . 

6. To move down, select the item and click . 

7. To delete a property, click . 

You cannot delete the property name of the Item 
ID. 

8. Click   to add Hose list columns. 

The Select Hose List columns checklist box 
displays. 

9. Select the required properties and click OK. 

The selected properties are displayed in the 
Hose List tab page- Configure columns. 

 
Hose List tab page 
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Unit: The Display with column header option 
shows the unit in the column 
header of the parts list column.  
The Display with property value option shows 
the unit with the property value of  
each row. 

Text: The Display in Upper Case option shows 
the list in the upper case.   
Also, you can change the text size of the list. 

Heading: The Heading dropdown selects the 
list header direction.  
For example, top, bottom or none. 

Direction: Sort the list in an ascending or 
descending order. 

10. Click OK. 

The selected properties are displayed in a 
tabular form when the Hose list is created in 
the drawing. 

 
Note:  
To learn more about Hose List, refer Chapter 60. 
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Ports List 

Customize the Ports List format. 

1. Click the Lists & Charts tab of HyDraw Options to select 
Ports List. 

The Ports List tab page displays. 

2. To rename a selected format,  

type the new name in the text box and then click  . 

3. To add a new format,  

type the new name in the text box and then click   
below the textbox. 

4. To delete a selected format, click   below the textbox.  

5. To move up, select the item and click  . 

6. To move down, select the item and click  . 

7. To delete a property, click  . 

You cannot delete Property Name of Item ID. 

8. Click  to add port list columns. 

The Select Ports List columns checklist box displays. 

9. Select the required properties and click OK. 

The selected properties are displayed in the Ports List 
tab page- Configure columns.  

Ports List tab page 
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Unit: The Display with column header option shows 
the unit in the column header of the parts list column.  
The Display with property value option shows the unit 
with the property value of each row. 

Text: The Display in Upper Case option shows the list 
in the upper case. Also, you can change the text size of 
the list. 

Heading: The Heading dropdown selects the list 
header direction. For example, top, bottom or none. 

Direction: Sort the list in an ascending or descending 
order. 

 

10. Click OK. 

The selected properties are displayed in a tabular 
form when the Ports list is created in the drawing. 

 

Note:  

To learn more about Ports List, refer Chapter 59. 
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Actuation Chart 

Customize the Actuation Chart format. 

1. Click the Lists & Charts tab of HyDraw Options and select 
Actuation chart. 

The Actuation chart tab page displays. 

2. To rename a selected format,  

type the new name in the text box and then click  . 

3. To add a new format,  

type the new name in the text box and then click    
below the textbox. 

4. To delete a selected format, click   below the textbox.  

5. To move up, select the item and click  . 

6. To move down, select the item and click  . 

7. Select the required properties and click OK. 

Text: The Display in Upper Case option shows the list 
in the upper case. Also, you can change the text size of 
the list. 

Heading: The Heading dropdown selects the list 
header direction. For example, top, bottom or none. 

Direction: Sort the list in an ascending or descending 
order. 

8. Click OK. 

The selected properties are displayed in a tabular 
form when the Actuation list is created in the drawing. 

 
Actuation Chart tab page 
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Net List 

Customize the Net List format. 

1. Click the Lists & Charts tab of HyDraw Options to select 
Net List. 

The Net List tab page displays. 

2. To rename a selected format, 

type the new name in the text box and then click . 

3. To add a new format, 

type the new name in the text box and then click  
below the textbox. 

4. To delete a selected format, click   below the textbox. 

5. To move up select the item and click  . 

6. To move down select the item and click  . 

7. Select the required properties and click OK. 

Text: The Display in Upper Case option shows the list 
in the upper case. Also, you can change the text size of 
the list.  

Heading: The Heading dropdown selects the list 
header direction. For example, top, bottom or none. 

Direction: Sort the list in an ascending or descending 
order. 

The selected properties are displayed in a tabular 
form when the Net list is created in the drawing. 

 
Net List page 
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Design Note 

Customize the Design Note List format. 

1. Click the Lists & Charts tab of HyDraw Options to select 
Design Note. 

The Design Note page displays. 

2. To rename a selected format, 

type the new name in the text box and then click  .  

3. To add a new format,  

type the new name in the text box and then click   
below the textbox. 

4. To delete a selected format, click    

5. To move up select the item and click  . 

6. To move down select the item and click  . 

7. Select the required properties and click OK. 

Text: The Display in the Upper-Case option shows the 
list in the upper case. Also, you can change the text 
size of the list. 

Heading: The Heading dropdown selects the list 
header direction.  
For example, top, bottom or none. 

Direction: Sort the list in an ascending or descending 
order. 

The selected properties are displayed in a tabular 
form when the Design Note list is created in the 
drawing. 

 
Design Note page 
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5. Library Path 

Multiple users have easy access to the library and components data from a common source over a network.  

1. Click the Library Path tab of HyDraw® Options. 

The Library Path tab page displays. 

2. Select the Local Library option.  

3. Select the Enable modification check box to modify 
library.  

The Modification menus are visible in the HyDraw 
Property Manager. 

4. Click Browse… 

5. Navigate to the folder where the HyDraw® library data is 
stored. 

6. Repeat above steps for each of the specified HyDraw 
library paths. 

7. Click OK. 

All the HyDraw library paths are configured. 

8. Select the Corporate Library option to configure second 
library path of your common Network library and repeat 
steps 3 to 7, if required. 

Data Library: This section specifies the folder path 
that contains component data, library listing data, 
and manifold manufacturing estimation data. 

Symbol Library: This section specifies the folder path 
that contains all libraries. 

Sub-Systems: This section specifies the folder path 
that contains user-created circuit drawings and its 
menu data. 

 
Library Path tab page 
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6. Misc. 

Configure text size, envelope line, symbol color, and solenoid naming convention for the US and Europe pattern.  
It also enables you to load the HyDraw® Library Explorer and the HyDraw Property Manager at startup. 

Click Misc. to display the tab page. 

 
Misc. tab page 

 Text Size  

1. In the Text size group box, select the appropriate text size from the 
respective list box for item ID and display properties. 

2. Click OK to effect the changes to the properties in the drawing. 

 

 
Text size section 
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Envelope Line 

1. In the Envelope line section, select the appropriate line pattern from 
continuous, phantom, and hidden list box options. 

2. Click the Color button to open the color box and select the required color. 

3. Enter the appropriate scale in the Scale textbox. 

4. Click the combo box to select a layer from 0, Def points, ISO_LIN_ASS, 
ISO_LIN_FLU, ISO_LIN_HAT, ISO_LIN_UNI, ISO_TEX_DES, ISO_TEX_DES_EU, 
ISO_TEX_DES_US, ISO_TEX_IDE, ISO_TEX_POS, PORT_SYM. 

5. In the Weight textbox, enter the appropriate weight of line. 

6. Click OK to effect the changes in the library.  

 
Envelope line section 

 Load on startup  

The Library Explorer and Property Manager can be loaded to HyDraw® on 
startup. 

1. In the Load on startup group box, select the application you want to use for 
loading on startup. 

The selected application loads and docks to the HyDraw drawing. 

2. Click OK to effect the changes. 

 

 
Load on startup section 

  



 

VEST, Inc. HyDraw® CAD 2019 33 

 

Symbol Color  

All symbols in the HyDraw® library are created with the ISO standard colors.  
You can also change the colors of these symbols to black. 

Select Change to black in the Symbol color section.  

1. Click OK to affect the changes in the drawing. 

 

 
Symbol color section 

 

 
 

 
Colored Symbol 

 

 
Black Symbol 
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Customize HyDraw Layer Properties 

Click Drafting Ribbon > Layer Properties 

The default HyDraw layers are listed in 
the dialog. 

 
Layer Properties Manager 
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Solenoid Naming  

Solenoid naming conventions for Directional Control Valve symbols are different for both US and Europe patterns. 
You can only view one naming convention for a pattern at a time. 

1. Select the appropriate pattern in the Solenoid naming section. 

The selected pattern will affect the change of solenoid naming of 
symbols in the HyDraw® drawing. 

2. Click OK to affect the changes. 

 

Solenoid naming section 

 
Solenoid naming –US pattern 

 

 
Solenoid naming – Europe pattern 

 
 

 
Solenoid naming 
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Command options  

1. Select the Show options on command line 
check box, if you need to show the selection 
options on the command line. 

2. Click OK to effect the changes. 

 
Note:  

If the Show options on command line option is 
deselected, only a few HyDraw® commands will 
display a dialog box. 

 
Command options 
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7. Internet Settings 

Configure the Internet connection for FluidPowerTools®. 

1. Click Internet Settings in the Services tab on the 
HyDraw® CAD ribbon menu. 

The Internet Settings of the HyDraw Options 
dialog box displays.  

2. Configure the required settings. 

 
 
Note: 

Refer Chapter 75, Para 2 for detailed configuration 
settings. 

 

HyDraw Options – Internet Settings Tab 
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8. Update from Excel 

Configure the Update from Excel settings for Update from Excel Interface. 

1. Select Update from Excel from HyDraw® 
Options. 

2. Browse the path of My local Excel data and 
select the ERP data. 

3. Browse and select the Service URL for the online 
Excel data. 

4. Search data by the Model Code or the Part 
Number. 

5. Click OK to save the update from Excel settings 
and close HyDraw Options. 

 
 
Note: 

• To create the ERP configuration XML file, go to 
Start > All Apps > VEST > HyDraw Library Manager 
2019 > HyDraw Update from Excel 2019. 

• For more details on how to use the HyDraw 
Update from Excel 2019, refer to the HyDraw 
Library Manager 2019 User Manual. 

 

HyDraw Options – Update from Excel Settings 
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9. Connection Tab 

Customize Connection properties for each connection line and configure Recommended velocity, Jumper, Dot (size) and Jumping Reference for the drawing.  

1. Click the Connection tab. 

The Connection tab page displays. 

2. In the Connection Properties group box, the 
Pressure, Reservoir, Control, Drain, Suction or 
Working lines are by default locked for editing. 
Deselect ISO, if required to edit.  
The Name is not editable for these six lines.  
Modify all other custom connection line 
properties like Name, Type, Line Type, Scale, 
Layer, Weight and Color by selecting each cell. 

3. Edit in place for Name and Scale. 

4. Select the Type from Pressure, Tank, Pilot, Drain 
or Suction. 

5. Select the Line Type from BYLAYER, 
CONTINOUS, PHANTOM, HIDDEN, DASHED etc 
from the drop-down preview. 

6. Select the Layer ISO_LIN_PRE, ISO_LIN_RES, 
ISO_LIN_CON, ISO_LIN_DRA, ISO_LIN_RES, 
ISO_LIN_WOR or any custom layer 

7. Select Weight from BYLAYER or any available 
line weight. 

8. Select Color from the drop down or pick from 
color palette. 

9. Set the recommended velocity for Pressure and 
Return Line. 

10. In the Jumper section, select the size of the 
jumper from large, medium, and small.  

11. In the Dot section, select the size of the 
connection dot from large, medium, and small.  

 
HyDraw Options – Connection Tab 
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Connection dot is automatically inserted 
when one line terminates on another. 

12. In the Jumping Reference section, 

o Select Use circuit type to display Circuit 
type option in the Jumping Reference 
command. 

o  Select Use grid square to display Grid 
square option in the Jumping Reference 
command. 

o Select Use auto insert to automatic 
insertion of jumping reference for the 
connection line. 

13. Click the Reset Connection Properties button if 
you want to reset all the values to default values 
from the HyDraw Library database. 

14. Click OK to apply and exit. 

 
Note:  
To add more custom connection lines,  
Refer HyDraw Library Manager 2019 Help, 
 Chapter No. 29. 
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10. Item ID 

Enclose the envelope ID, component ID, accessories ID, hoses ID, and sub-system ID. 

1. Click the Item ID tab of HyDraw® Options. 

The Item ID tab displays. 

2. Select the ISO 1219 numbering scheme or 
Sequential Numbering. 

Enter the Item ID starting number and 
Group by component code or identical items 
for sequential numbering. 
Select the separator and count, per 
requirement. 
This helps in the identification of the 
component. 

3. Select the Same scheme as Components 
option in the Hoses section to enable hoses 
to follow the numbering scheme. Else, 
provide separate numbering scheme for 
hoses. 

4. Select the As sub item of component 
checkbox to number the accessory same as 
the sub-item of the component. 

5. Select Separator and Accessory ID to define 
the accessory Item ID. 

6. Select the List component as first sub-item 
checkbox to number the first sub-item. 

7. Select the Assembly ID checkbox to display 
the Assembly ID in the drawing. 

8. Select Accessory Item ID in the Display 
section to show the accessory item ID in the 
drawing. 

 

 
HyDraw Options – Item ID Tab 
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9. Select Stack horizontally or Stack vertically 
to orient accessory IDs and its balloons with 
component Item IDs.  

10. Click OK to save and exit. 
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11. Gauge Port 

Configure the Gauge port settings. 

1. Click the Gauge port tab of HyDraw Options. 

The Gauge port tab page displays. 

2. Configure the default gauge port type, size and 
prefix. 

3. Set the Gauge port insertion distance default 
values in the External Port tab. 
Else, set the locations in this tab. 

4. Select the default symbols for the Open and 
Close options from the drop down. 

5. Click OK to save and exit. 

 
 
Note: 

For more information, refer chapter No.16. 

 

 
HyDraw Options – Gauge Port 
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12. Property Display 

Customize Show/Hide display format in the drawing. 

1. Click Property Display tab of HyDraw Options. 

The Property Display page displays. 

2. Select/Deselect the display properties in 
following sections, Components, External Ports 
and Connections. 

Click None, to deselect all the display formats of 
Components, External Ports and Connections to 
Hide. 

Click Select All, to select all the display formats 
of Components, External Ports and Connections 
to Show. 

3. Click Reset, if you want to update the list of 
display formats from the HyDraw Library 
database. 

4. Click OK to save and exit. 

 
Note: 
The space between the displayable properties is 
automatically controlled. 

 
HyDraw Options – Property Display  
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13. Drawing Template 

Assign Drawing templates to the Sheet size from the Template folder. 

1. Click Drawing Template tab of HyDraw Options. 

The Drawing Template page displays. 

2. Click the Browse button to select the Drawing 
template path. 

3. Assign Drawing template from file name drop-
down as per the sheet size. 

4. Click OK to save and exit. 

 

 

Caution: 

Define Title Block and Border name as per the title 
block and border name saved in the template. 

 
 

Note: 

Default Template path should be 
“C:\Users\User\AppData\Local\VEST\HyDraw CAD 
2019\R2019\enu\Template". You can also assign 
custom template path. 

 
HyDraw Options – Drawing Template 
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14. Balloon 

Configure the Balloon type. 

1. Click the Balloon tab of HyDraw 
Options. 

The Balloon tab page displays. 

2. Select the default Balloon type for 
Component, Sub-System, 
Accessory and Hose. 

3. Select the No balloons on external 
ports check box, if you don’t want 
any balloon on the external port 
name. 

4. Click OK to save and exit. 

 

 
HyDraw Options – Balloon 
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Insert Symbols 
 

 
 
 
 
 
 
     

9 Insert Symbol 

10 Insert External Port 

11 Insert Sub-Systems 

12 Insert from Parts List 

13 Insert Terminators 

14 Insert Symbol Port 

15 Insert Envelope 

16 Insert Gauge Port 

17 Insert Orifice Disc 

18 Insert Jumping Reference 
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9. Insert Symbol 
Search component type, search symbols, insert symbols, insert external ports, search sub-systems and insert sub-systems into the drawing.  

The Insert Symbol command is on the 
Circuit tab of the HyDraw® CAD ribbon 
menu. 

The Component library is a logically 
structured symbol library of hydraulic, 
pneumatic, and electrical systems. 

 

Logically structured Component Library 
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1. Search and Insert Symbol by Component type 

1. Enter the required component 
type of symbol. 

2. Click  search button. 

3. Select the appropriate library and 
navigate to the required symbol. 

4. Drag the symbol from the HyDraw® 
Library Explorer window on the 
drawing. 

 

Alternatively: 

1. Double click the symbol on HyDraw 
Library Explorer window. 

Symbol preview appears on the 
drawing space. 

The Specify insertion point 
prompt displays. 

2. Specify the Insertion Point or 
Select Rotate/Flip option.  
Rotate, Left/Right or Flip, 
Vertical/Horizontal.  

The symbol is placed on the 
drawing. 

Note: 

You can also use wild characters Percent 
(%) or Asterisk (*) to search by 
component type.  

 

 
Search library by Component Type 
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Replace Symbol 

1. Select the Symbol to replace in the 
drawing. 

2. Select the Replace symbol check 
box in the HyDraw® Library 
Explorer. 

3. Drag and drop the new symbol in 
the drawing. 

 
 

Alternatively: 

1. Double click the new symbol on 
HyDraw Explorer window. 

Symbol preview appears on the 
drawing space. 

The Specify insertion point 
prompt displays. 

2. Specify the Insertion Point or 
Select Rotate/Flip option. Select 
Rotate Left/Right and/or Flip, 
Vertical /Horizontal.  

The Symbol is replaced on the 
drawing. 

 

 
Replace Symbol from Library into drawing 
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2. Insert a Symbol by Library 

1. Select the appropriate library and 
navigate to the required symbol. 

2. Drag the symbol from the HyDraw® 

Library Explorer window on the 
drawing. 

Alternatively: 

1. Double click the symbol on HyDraw 
Library Explorer window.  

Symbol preview appears on the 
drawing space. 

The Specify insertion point 
prompt displays. 

Automatic ID is assigned to 
symbols based on the scheme 
set in HyDraw Options – Item ID 
tab. 

2. Specify the Insertion Point or 
Select Rotate/Flip option. Select 
Rotate Left/Right and/or select 
Flip, Vertical /Horizontal.  

The symbol is placed on the 
drawing. 

Note: 

Copied symbols also get automatic IDs 
based on the scheme set in HyDraw 
Options – Item ID tab. 

 
Double click or Drag and drop symbol  
from Library into the drawing 
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Replace Symbol 

1. Select the Symbol to replace in the 
drawing. 

2. Select the Replace symbol check 
box in the HyDraw Library 
Explorer. 

3. Drag and drop the new symbol on 
the drawing. 

 

Alternatively: 

1. Double click the new symbol on 
HyDraw Explorer window. 

Symbol preview appears on the 
drawing space. 

The Specify insertion point 
prompt displays 

 

2. Specify the Insertion Point or 
Select Rotate/Flip option. Select 
Rotate, Left/Right and/or select 
Flip, Vertical /Horizontal.  

The Symbol is replaced on the 
drawing. 

 

 
Replace Symbol from Library into the drawing 
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3. Search and Insert Symbol by Components 

1. Click  button in the Search 
section. 

The Search section page 
displays. 

2. Select appropriate search 
database,  
My local database or 
FluidPowerTools.com database.  

If the My local database option 
is selected, 
the program searches 
components in the user’s local 
database. 

If the FluidPowerTools.com 
database option is selected,  
the program searches 
components by manufacturer 
as set in the HyDraw CAD 2019 
   > Services 
      > Data Access Settings 

 

 
Services - Data Access Settings dialog box 

 

 
Default Search tab page 
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3. Select the required application, such as Hydraulic, Pneumatic or Electrical. 

If the Application Type, Hydraulic, is selected, then the program searches 
only for components applicable to hydraulic. 

 

4. Enter the Model Code to search a particular component. 
Or 
Enter the Part Number to search a particular component, 
If My local database is selected. 

 
Enter Model Code 

 5. Select the manufacturer from the drop-down list, 
if My local database is selected. 

 

Manufacturer options 

6. Select the appropriate component group from the drop-down list. 

 

Component group options 
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7. Select the appropriate component type, if All Component Groups is selected 
in the component group. 
Or 
Select the component type as per selected component group. 

 

Component type selected as per component group selection 

 

8. Define more criteria. 

 
Define More Criteria options 

 
8.1   For precise search, define custom search parameters by model 

properties. 

8.2   Click  to view the Select Property box, which displays common 
properties. 

 8.3   Select the property you want to assign.  

8.4   Enter the property value, for example 10,  
or range, for example 10-20.  

Property range must be separated by a hyphen (-). 

 
 

9. Select Property. 

 

Select Property  
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10. Click the Search button. 

All model codes or model family with assigned custom properties are 
displayed in the Search result pane. 

 
Search Model code with precise criteria  

 11. Select the appropriate model code or model family in the preview pane. 

The Search results are displayed in the pane. 

 
Preview symbols 
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Filter Search Results 

On mouse hover the property header, 

click button to select the required 
property value. 

The Available models display as per 
selected property value. 

By default, all properties value 
displays in the available models. 

 

 

 
Search Result – Filter 

 

 
Search Result – Select property value 

 

Clear Selection 

Click  button to clear the model selection. 

Symbols are displayed in the preview pane as 
per search criteria. 
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Models Context Menu 

• Right click and select Search for 
complete Model Code from the 
context menu to display the model 
codes for the selected model family. 

The Model Code results display 
with model family. 

• Right click and select View Model 
Properties from the context menu 
to display the component data 
window. 

The Component Model 
Properties window displays 
details of the component. 

• Right click and select View Data 
Sheet from the context menu to 
view the data sheet attached to the 
model code. 

 

 
Models context menu 

 

 
Component data 
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1. Click Close button to return to the main search window  
and search with different inputs, if required. 

 

 
Close search results 

 2. Select the symbol in the preview pane; drag and drop 
Alternatively, double click the symbol to insert the symbol into the drawing. 

3. Replace the symbol in the drawing with another one from the library by 
selecting the Replace symbol checkbox in the HyDraw Library Explorer 
window, if required. 

4. Drag and Drop the symbol in the drawing 
Alternatively, double click the symbol to insert the symbol in the drawing. 

The Specify insertion point prompts displays. 

5. Specify the Insertion Point or Select Rotate/Flip option. 

The symbol is inserted in the drawing. 

 
Symbol dragged and dropped into the drawing 
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Auto Naming and Grouping of Components 

Assigns sequential Numbers to the Component Symbols and groups Identical Component Symbols when inserted in the Drawing. 
 

Insert Symbol from Library 

• By Default, symbols will be inserted following 

Sequential Numbering option in Item ID. 

• Inserting symbols from Library assigns Numeric 

values with the increment of 1. 

      
Symbol during Insertion 

 
Inserted Symbol with Automatic ItemID 
 
 

Insert Symbol from Component Search 

• By Default, symbols will be inserted following 

Sequential Numbering option in Item ID. 

• Inserting Component Symbols from Search has 

Model Properties filled and identified as a 

Component Directly. 

• Inserting same symbol with Property values 

filled, groups the Symbols following the options 

set for Item ID in HyDraw options. 

 
Note:  
For Automatic Grouping of Components, Grouping 
option must be selected in HyDraw options>Item ID. 
Refer Ch. 8 - HyDraw Options> Item ID  

 
Symbol with Component Data during Insertion 

 
Inserted Component Symbol with Automatic Item ID -
Grouped 
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Insert Symbol from Parts List 

• Parts List is assigned with Item ID for all Components 

when loaded. 

• By default, symbols will be inserted based on the 

Sequential Numbering option selected in the Item ID tab. 

• Inserting Symbols from Parts List has Model Properties 

filled and identified as a Component Directly. 

• Inserting same symbol from Parts List groups the 

Symbols following the options set for Item ID in HyDraw 

options. 

 

 

Symbol Inserted from Parts List – Automatic Item ID 

Note: 

• Copying and Inserting HyDraw symbols in the drawing is 
based on the automatic naming and smart grouping of 
Item IDs set in HyDraw Options. 

• Mirroring a schematic or a portion in the drawing is based 
on the automatic naming and smart grouping of Item IDs 
set in HyDraw Options. 

• For ISO Numbering scheme, the first item ID is manually 
provided by double clicking the Item ID or the HyDraw 
Property Manager. 
The program stores the prefix and generates automatic 
Item ID based on the last used ID. 
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10. Insert External Port 
Insert ports on the envelope line in a circuit drawing.  
Configure and edit the ports to suit the circuit requirements. 

1. Click  tab on the HyDraw® Library Explorer 
window. 

The External Port Library tab page displays. 

2. Click on the Configure External Port caption bar to 
expand,  
if the section is not open. 

3. Type the Item ID in the text box,  
for example, P, T, 1.  
The default Item ID is ‘?’. 

4. Select Pressure line port or Return line port. 

5. Enter parameters for Pressure and Flow. 

6. Select Port Type from SAE O-ring, SAE Flange, BSP, 
NPT, and Metric.  

On selection, different port sizes of the respective 
port type are displayed automatically. 
Choose the required one.  

7. Select and drag the plugged or unplugged port from 
the preview section on the drawing.  
Alternatively,  
Double click the plugged or unplugged port.  

Specify insertion point displays on the command 
window.  

Once you specify the insertion point, the port is 
inserted into the drawing. 

If the port symbol is placed over the envelope line, 
it attaches itself to the envelope line. 

 
External Port Library tab page 

 
External Port inserted into the drawing 

  



 

VEST, Inc. HyDraw® CAD 2019 63 

 

Port Data - Select from Library 

1. Click Circuit > Edit  on the HyDraw® CAD ribbon 
menu. 

The HyDraw Property Manager window displays. 

2. Select the external port. 

The HyDraw Property Manager displays the 
properties of the external port. 

3. Click  on the Port data caption bar to select the 
port data from the library. 

The Configure External Port dialog box displays. 

4. Select the Pressure line port/Return line port. 

5. Select Port Type from the drop down: SAE O-ring, 
SAE Flange, BSP, NPT, and Metric.  

On selection, different port sizes of the respective 
port type are displayed automatically. 

6. Select the required Port Size 

7. Click OK to choose the selected port data from the 
library. 

 
Note:  

The port data can embed With O-ring and With Through 
Bolt Hole from HyDraw to MDTools®. 

 

 

HyDraw Property Manager – Port 
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Configure External Port 

Configure different external ports shape. 

1. Click  on the HyDraw® CAD ribbon menu. 

2. Click the External Port tab. 

The External Port tab page displays. 

3. Select the appropriate port shape, such as circle, 
oval, line, rectangle, or square.  

The respective shape displays in the Port Preview 
section of the HyDraw Library Explorer window. 

The external port can be placed on the envelope 
line of the circuit. 

4. Click OK to apply and exit. 

 
External Port tab 
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Replace External Port 

Replace the port in the drawing with another port from the library. 

1. Select the symbol to replace in the drawing. 

2. Select the Replace symbol checkbox in the HyDraw® 
Library Explorer window, if required. 

3. Drag and drop the new port on the drawing. 
Alternatively, 
Double click the plugged or unplugged port.  

The Specify insertion point displays on the 
command window.  
Once you specify the insertion point, the port is 
replaced on the drawing. 

If the port symbol is placed over the envelope 
line, it attaches itself to the envelope line. 

 
Replace symbol, Unplugged with Plugged External Port 
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11. Insert Sub-Systems 
Search and Insert Sub-Systems from Library into the drawing. 

1. Insert Sub-System from Library 

1. Select the appropriate library and navigate to 
the required sub-system. 

2. Drag the sub-system from the HyDraw Library 
Explorer window into the drawing. 
 
Alternatively, 
Double click the sub-system on HyDraw Library 
Explorer window.  

Sub-System preview appears on the drawing 
space. 

The Specify insertion point prompt displays. 

 

3. Specify the Insertion Point or Select Rotate/Flip 
option. Select Rotate Left/Right and/or select 
Flip, Vertical /Horizontal. 

The sub-system is placed on the drawing. 

 

 
Double click or Drag and drop sub-system from Library into the drawing 
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Explode Sub-System 

1. Select the Sub-System to explode in the 
drawing. 

2. Select the Explode Sub-System check box in the 
HyDraw Library Explorer. 

3. Drag and drop the new sub-system on the 
drawing. 
 
Alternatively, 
Double click the new sub-system on HyDraw 
Explorer window. 

Sub-System preview appears on the drawing 
space. 

The Specify insertion point prompts displays 

4. Specify the Insertion Point.  

The Sub-System is exploded on the drawing. 

 
Explode Sub-System from Library into the drawing 
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2. Search and Insert Sub-Systems 

1. Click  button in the Search section. 

The Search section page displays. 

 

Default Search tab page 

 
 

2. Enter the Model Code to search a particular sub-system type. 

 

 
Enter Model Code 
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3. Select the manufacturer from the drop-down list. 

 
Manufacturer options 

 

4. Select the appropriate Sub-System type from the drop-down list. 

 
Sub-System type options 

 

 5. Define more criteria 

 
Define More Criteria options 

▪ For precise search, define custom search parameters by model 
properties. 

▪ Click  to view the Select Property box, which displays common 
properties. 

▪ Select the property you want to assign.  

▪ Enter the property value, for example 10,  
or range, for example 10-20.  

Property range must be separated by a hyphen (-). 

6. Select Property. 

 

        Select Property dialog 
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7. Click the Search button. 

All model codes with the assigned custom properties are displayed in the 
Search result pane. 

 
Search Model code with precise criteria  

 8. Select the appropriate model code in the preview pane. 

The Search results are displayed in the pane. 

 
Preview sub-systems 
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Filter Search Results 

On mouse hover the property header, click 

button to select the required property 
value. 

The Available models display as per 
selected property value. 

By default, all properties value displays 
in the available models. 

 

 

 
Search Results – Filter 

 

 

Search Results – Select property value 

Clear Selection 

Click  button to clear the model 
selection. 

Sub-Systems are displayed in the 
preview pane as per search criteria. 
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Models Context Menu 

Right click and select View Model Properties 
from the context menu to display the sub-system 
data window. 

The Sub-System Model Properties window 
displays details about the sub-system. 

 
Model context menu 

 
Sub-System data  
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9. Click  Close button to return to the main search window  
and search with different inputs, if required. 

 
Close search results 

10. Select the sub-system in the preview pane; drag and drop. 
Alternatively, double click the sub-system to insert the sub-system in the 
drawing. 

a. Explode the symbol in the drawing from the library by selecting the 
Explode Sub-System checkbox in the HyDraw Library Explorer 
window, if required. 

b. Drag and drop the sub-system on the drawing 

Alternatively, double click the sub-system to insert the sub-system in 
the drawing. 

The Specify insertion point prompts display. 

 

 11. Specify the Insertion Point or Select Rotate/Flip option. 

The sub-system is inserted in the drawing. 

 
Sub-System dragged and dropped in the drawing 
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12. Insert from Parts List 
Insert symbols from Parts List in Excel.  

Note: Each item in the Parts list is identified by its 
unique model code. Therefore, the Parts list must 
contain a model code for each item in the list. 

1. Select Circuit > From Parts List > Insert Symbol 
on the HyDraw® CAD ribbon menu. 

The Insert Symbol from Parts List dialog box 
displays. 

2. Enter the Part list starting row at option and the 
Model Code column number. 

3. Click Browse...  

The Select Parts List Excel file dialog box 
displays. 

4. Select the required Excel file containing the 
Parts list and click Open. 

Contents of the Excel file are displayed. 

5. Type Model Code column number in the 
textbox, if it is not automatically entered. 

6. Select the Models and click Insert or Insert All 
to insert all the symbols in the drawing. 

Linked Symbols dialog box displays when 
multiple symbols are linked to the selected 
model. 

For Insert symbol detailed information, refer chapter 
no 9. 

 
Insert Symbols from Parts List dialog box 

 
Insert Linked Symbol from Parts List 
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13. Insert Terminators 
Insert terminators dynamically for any unused component ports and connection lines. 

1. Click Circuit > Terminator  on the HyDraw® 
CAD ribbon menu. 

The Select symbol port prompt displays. 

2. Select the symbol port for the terminator 
insertion. 

The terminator is inserted at the location. 

Terminators are inserted automatically for all 
unused ports of all selected symbols and sub-
systems. 

Note: 

• The terminator indicates the unused component 
port. 

• Terminator is essential in the Net List creation.  
A net remains incomplete, if a port is left 
unconnected.  

• The Net list can indicate unconnected circuit lines 
and ports. 

• When you rotate the symbol and sub-systems, 
the terminator also rotates along with it. 

 

 
Dynamic terminators 
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14. Insert Symbol Port 
Insert connection points on the ports of a symbol. 

1. Click Circuit > Insert Symbol port   on the 
HyDraw® CAD ribbon menu. 

The Select Symbol to Insert Port prompt 
displays. 

2. Select the symbol. 

The Port Name: prompt displays. 

3. Enter the Port Name in the command window 
and press the Enter key. 

The Other Name: prompt displays. 

4. Enter the other name in the command window, 
if required and press the Enter key. 

The Specify Port Insertion Point: prompt 
displays. 

5. Specify the Port Insertion point on the symbol.  

A small red cross appears at the point where 
the port is inserted. 

 

 
Inserting a Symbol Port 
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15. Insert Envelope 
Insert an envelope to define a boundary for a manifold or a system. 

1. Click Circuit >  Envelope on the HyDraw® CAD ribbon menu. 

The Specify first corner point prompt displays. 

2. Select the first corner point on the drawing. 

The Specify other corner point prompt displays.  

3. Select the other corner point on the drawing. 

The envelope is inserted. 

The smart envelope has following functionalities: 

a. Insert ports automatically on the envelope line intersection with 
connection lines. 

         

Ports automatically inserted on envelope line intersection   

 

 
Envelope data of the selected Envelope Line 

b. Hanging connection lines automatically deleted when automatic insertion of ports on the 
envelope line. 

c. Envelope line is made of polyline and can be easily resized by the resize handle. 

d. External ports are glued to the envelope and relocates the ports and maintain connectivity 
while resizing the envelope. 

e. Envelope data is attached to the envelope line. 
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16. Insert Gauge Port 
Insert a gauge port to define a boundary for a manifold or a system. 

1. Click Circuit >  Gauge on the HyDraw® CAD 
ribbon menu. 

The Select ports to insert gauge port prompt 
displays. 

2. Select the external port(s) on the drawing. 

The Port type (Open/Close) prompt displays.  

The default symbol also displays. 

The insertion location 
[Above/Below/Left/Right] prompt displays.  

HyDraw inserts the gauge ports for all the 
selected external ports and automatically 
inserts Item ID and connects using the 
connection line. 

3. To configure the gauge port, select the Gauge 
tab option. 

 

 
Gauge port GP is inserted in parallel to the existing selected external port 
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17. Insert Orifice Disc 
Insert an orifice disc for Port #1 of cartridge symbols and external ports. 

1. Click Circuit > Orifice Disc on the HyDraw® CAD 
ribbon menu. 

The Select a Symbol prompt displays. 

2. Select the symbol. 

Insert Orifice Disc dialog box displays. 

3. Select the orifice disc symbol which you want insert. 

4. Select the model data linked to the symbol. 

5. Click OK. 

A warning message box displays, if you select 
unconnected symbol Port #1 or Port #1 is not 
available in the cartridge symbol. 

Symbol preview appears on the drawing space. 

6. Click on the drawing space or Select any of the Flip, 
Vertical /Horizontal options.  

The Orifice Disc is automatically inserted on the Port 
#1 of the selected cartridge symbol or external port on 
the drawing. 

 
Note: 

• Individual symbols of Cartridge symbol and Orifice disc are 
combined with “&” and accepted as a single entity in the 
HyDraw Export to MDTools. 

• Orifice Disc item ID should not be listed, when creating 
Net List. 

 
Orifice Disc automatically inserted on Port #1 of the cartridge symbol 

 
Orifice Disc automatically inserted on the INT port of the external port 
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18. Insert Jumping Reference 
Insert jumping reference to the unconnected end of a connection line. 

1. Click Circuit > Jumping Reference on the HyDraw® 
CAD ribbon menu. 

The Select connection line prompt displays. 

2. Select the unconnected end of a connection line. 

A warning message box displays, if you select a non-
free end connection line. 

The Insert Jumping Reference dialog box displays. 

3. Enter the Name of jumping reference. 

4. Select the Circuit type from drop-down list,  
If the Use circuit type option is selected in the HyDraw 
Options > Connection > Jumping Reference. 

5. Enter the Destination sheet. 

6. Enter the Grid square, If the Use grid square option is 
selected in the HyDraw Options > Connection > Jumping 
Reference. 

7. Click OK. 

The jumping reference is automatically inserted 
vertically or horizontally on the unconnected end of a 
connection line. 

On the basis of connection line segment, jumping 
reference is automatically inserted vertically or 
horizontally on the connection line.  

Note: 

You cannot create jumping reference with the same name for 
more than one pair of unconnected connection line. 

 
Jumping Reference automatically inserted on unconnected end of the connection line 
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Make Connections 
 
  

19 Insert Connection 

20 Connect Ports and Symbols 

21 Fetch Pipe, Tube and Hose Data 



 

VEST, Inc. HyDraw® CAD 2019 82 

 

19. Insert Connection 
Interconnect symbols and create a circuit. 

Auto Connect: The Auto Connect property, when enabled before making a 
connection, automatically creates the connection between the two selected points.  

When the Auto Connect property is disabled, the connection has to be created 
manually between the selected points.   
When Ortho is ON, the termination point can be selected only in the four mutually 
perpendicular directions of the starting point.  
When Ortho is OFF, the termination point can be anywhere around the start point. 

 

1. Enable/Disable Auto Connect on the HyDraw® CAD ribbon menu. 

2. Click on the Connection type from Pressure, Reservoir, Control, Drain, Suction, 
Working or Custom from Line1, Line2, Line3, Line4, and Line5 options on the 
HyDraw CAD ribbon menu. 

Connection lines are assigned with the default ISO color and line weight. 

You can customize the connection lines. 

The Select first connection point prompt displays. 

3. Select the first connection point on the drawing as the start point. 

When the Auto Connect option is enabled: 
The Select second connection point prompt displays. 

4. Select the second connection point as the termination point. 

When the Auto Connect option is disabled: 
The Select Next point prompt displays. 

5. Select the next connection point.  

6. Press the Enter key when the connection is complete. 

The connection line is drawn between the two points. 

7. Customize the connection lines, if required. 

Note: 

• If a connection is drawn at the end/start of another same type connection line 
with a tolerance of 0.1” or 2.54 mm, the connection lines automatically merges 
to a single polyline. 

• If a connection line is drawn without connecting symbol ports or connection 
lines, the jumping reference is automatically placed on the unconnected end of 
the connection line, if the Use auto insert option is selected on the HyDraw 
Option > Connections > Jumping Reference. 

 

 

 

 

 
Insert Connection sub menus 
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20. Connect Ports and Symbols 
 

To connect two ports of different symbols,  
click one port of a symbol and then click the other 
port.  

When two lines cross each other, a jumper is 
inserted over one line dynamically. This indicates 
the connection is not ended. 

When one line terminates on another,  
a connection dot is inserted dynamically at the 
termination point. 

 
Note: 

• To insert jumpers automatically for non-
intersecting connection lines,  
set the option in the Connection tab of the 
HyDraw® Options ribbon menu. 

• Connection dots are inserted automatically when 
one connection line terminates on the other. 

 

 
Connection lines inserted to create circuit 
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21. Fetch Pipe, Tube and Hose Data 
Connection lines can be assigned to the Tube, Pipe and Hose data from the library, based on the design requirements. 
Specify Connector type for the connection line to select the default connection properties from the library. 

1. Select the connection line. 

2. Select the connector type from the drop-down list. 

3. Specify the design requirements, pressure and flow for 
the selected connection lines in the HyDraw® Property 
Manager. 

4. Click the Select from Library icon. 

The Fetch Pipe/Tube/Hose from Library dialog box 
displays. 

5. Select either Pressure line or Return line. 

6. Select Type, i.e. Pipe/Tube/Hose. 

7. Select Material. 

Pressure and flow are automatically displayed in the 
Design requirements section.  
Velocity is displayed per the recommended velocity set 
in the HyDraw Options dialog box. 

The inner diameter is based on the flow and velocity, 
and the appropriate pipe/tube/hose is selected by 
default in the grid displaying all the other available 
pipes/tubes/hoses with velocity. 

8. Select the required pipe, tube or hose. 

9. Click OK and exit. 

 
Note: 

For Drill Hole and Electrical type connector, the Select from 
Library option is not applicable. 

 
HyDraw Property Manager – Connection Data 

 
Fetch Pipe/Tube/Hose from Library 
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Modify Connection 
 

 
  

22 Stretch Connections 

23 Match Connections 

24 Merge Connection 

25 Reset Connections 
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22. Stretch Connections 
Stretch an existing connection line. 

1. Click Circuit > Stretch Connection  on the 
HyDraw® CAD ribbon menu. 

The Select a connection prompt displays. 

2. Select a connection line. 

The Specify point prompt displays. 

3. Click a point on the drawing to specify the new 
location of the connection line. 

The connection line gets stretched. 

 
 
 
 

 
Stretching the connection  

 
 
 
 
 

 
Circuit after Stretching the connection 

  

Stretching a 
connection line 

Stretched to the new 
location 



 

VEST, Inc. HyDraw® CAD 2019 87 

 

23. Match Connections 
Match the connection properties of one connection line with another. 

1. Click Circuit > Match Connection  on the 
HyDraw® CAD ribbon menu. 

The Select Source Connection prompt 
displays. 

2. Select the source connection line. 

The Select Destination connection(s) prompt 
displays. 

3. Select a single line or multiple connection lines. 

4. After completion of selection, press the Enter 
key. 

The connection properties are copied. 

 

 

Circuit Before Matching Suction Connection line 
 with Pressure Connection Line 

 
 

 
Circuit After Matching Connection 

  

Match Orange to 
Green 

Matched 
Connection Line 
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24. Merge Connection 
Connect the same type HyDraw connection lines that are disconnected within specified tolerance. 

1. Click Circuit > Merge Connection  on the 
HyDraw® CAD ribbon menu. 

The select connections prompt displays. 

2. Select two or more connection lines. 

3. After completion of selection, press the Enter 
key. 

A warning message box displays. 

4. Click OK to continue or click Cancel to exit. 

The same type connection lines are merged 
to a single polyline, if the distance between 
two adjacent end/start points of two 
connection lines are within tolerance of 0.1” 
or 2.54mm. 
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25. Reset Connections 
Convert a bend (slanting) connection line in to a right angled connection line. 

1. On the command window (line), type the 
Resetcon command. 

The Select a connection prompt displays. 

2. Select the connection line that you want to 
reset. 

The connection line resets to the right-angled 
connection line. 

 
Connection Lines (Before Reset) 

 
Connection Line (After Reset) 

  

Reset Connection 
Line 

Connection Line 
after Reset 
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Specify Properties 
 

 
 
 

  

26 Selected Item Properties 

27 System Properties 

28 Edit Properties 

29 Copy Properties 

30 Refresh Properties 

31 Update Property List 

32 Purge Properties 

33 Purge Price Data 

34 Edit Solenoid Information 

35 Update from Excel 



 

VEST, Inc. HyDraw® CAD 2019 91 

 

26. Selected Item Properties 
Properties assigned to the selected symbol or sub-system in the drawing is displayed.  
Add new accessories to the symbol or sub-system and save it to the library. 

Select the symbol or sub-system in the drawing. The Selected Item tab page displays the following sections: 

1. Symbol 

The Symbol section displays the ID, balloon style, and 
various display settings of the symbol or sub-system. 

• Customize the balloon style to circle, oval, 
rectangle, rounded rectangle, hexagon or none of 
these.  

• Show or Hide various display settings with the 
symbol on the drawing.  

• Click  to expand and then select Hide or Show 
to hide or show the respective parameters. 

• Select the checkbox on the caption bar to include 
the Selected Item properties in the respective 
component Parts List of the circuit. 

 
Selected Item tab page 
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2. Design Requirements 

The Design requirements section enables you to 
search for the required components by specifying a 
design parameter and value, from the library. 

1. Type the value in the text box of the respective 
parameter. 

2. Click  on the Design Requirements caption 
bar to open Edit Port Operating Parameters.  

3. Specify separate flow and pressure for each port 
of a component. 

4. Click  on Edit Design Note to add the design 
notes to the component.  

The Design Note icon appears on the top of 
the Item ID. 

 

 
Edit Port Operating Parameters 

 
 

 
Symbols with design Notes 
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3. Model Data 

Displays the details of the component selected. 

Model data of the Component is the Model 
Properties. 

1. Enter the values of Properties manually to fill in 
the Model Data. 

or 

2. Use    Select from Library to fetch the data 
from HyDraw Library. 

 
 

Follow the steps in next section 4, to Select Data from 
Library. 

 

 
Model data section 
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4. Select from Library 

1. Select model data for a component using either the 
Local database installed on the system  
OR 
Online database of FuidPowerTools.com 

Click  on the Model Data caption bar to fetch the component from 
the library. 

The Select from Library dialog box displays with the input data. 

2. Select the database to search, i.e.,  
My local database or Fluidpowertools.com 

If the My local database option is selected,  
the program searches the component in the local database of the 
user. 

If the FluidPowerTools.com database option is selected,  
the split button on the right is enabled,  

Data Access Settings 

• In the Data Access Settings, select manufacturer database to 
search for components. 

The Data Access Settings drop down provides other controls,  
which includes:  
Data Access Settings, Data library and Help topics, Usage terms and 
conditions, My Subscriptions information, and Contact. 

• Click Models linked to symbol to display the component models 
linked to this symbol. 

•  Click all models to display all component models available to the 
component type of the symbol. 

• Click the Search button to search for the component.  

The search results display in the Search results pane. 

Click OK. 

 

 
Select from Library - Data Access Settings 
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Add Accessories 

You can add or replace accessories of the model code 
to the symbol by selecting an appropriate button.  

• Select the Include accessories check box,  
and then select Add. 

The linked accessories of the component 
model will be added to the selected model. 

 
 

Replace Accessories 

• Select the Include accessories check box,  
and then select Replace. 

The linked accessories of the component 
model will be added to the selected model 
and all accessories linked previously will be 
delinked. 

 
 

Saving Model Data into Library 

You can save the designed component with 
customized data in the library. 

• Click  on the Model Data caption bar to save 
custom details in the library. 

 
Select from Library with Search results 

 

 
Save to Library 
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5. Pump Motor Adaptor Data - Select from Library 

1. Click Circuit > Edit  on the HyDraw® CAD 
ribbon menu. 

The HyDraw Property Manager window 
displays. 

2. Select the adaptor. 

The HyDraw Property Manager displays the 
properties of the adaptor. 

3. Click  on the Model data caption bar to select 
the Model data from the library. 

The Pump/Motor Adaptor dialog box displays.  
Automatically all the properties of the 
respective motor and pump populates, and the 
most appropriate data is selected.  

4. Select the required adaptor. 

5. Click OK to select the adaptor data from the 
library and populate in the Property Manager. 

Note: 

• Pump and Motor symbols must be close enough to 
touch the adaptor both ends. 

• The Pump and Motor must have certain properties 
already defined (E.g. Frame Size, Pump Mount and 
Shaft length) in order to prompt for a selection. 

• You can do an embedded search for a single Motor 
Frame Size and Pump Mount from a multiple values 
that are separated by slash (/). 
E.g. Motor Frame Size: 145TC/245TC/.. etc. 
        Pump Mount: SAE 2B/SAE 4B/.. etc. 

 
Pump/Motor Adaptor Data 
 

 
Property Manager: Model data 
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6. Accessories 

The Accessories section displays the details of accessories assigned with the item.  
This section also displays all documents and CAD files linked with the accessory. 

7. Select from Library 

Fetch required accessories for your component from the library. 

1. Click  on the Accessories caption bar to open Select Accessories from Library dialog box. 

2. Select Accessories or Components. 

3. Select the required manufacturer and component type. 

4. To refine the search, type the Model Code,  
and then click Search. 

All available accessories of the selected component type display in the Available accessories pane. 

5. Define more criteria, 

➢ For precise search, define custom search parameters. 

➢ Click  to view the Select Property box, which displays common properties. 

➢ Select the property you want to assign.  

➢ Click OK. 

6. Click Search. 

All available accessories of the selected component type display in the Available accessories pane. 

7. Select the model code you want to add to your circuit. 

8. Click Add. 

The added model codes display in the Selected accessories pane. 

9. Select the model code and click Remove to remove the selected model code from the selected accessories pane. 

10. Click OK. 

All the selected accessories are added to the component and displayed in the Accessories pane on the Selected 
Item tab page. 

 
Fetch Accessories from Library 

   
Selected accessories 
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Add New Accessories 

Add new accessories to the selected item and save in the library. 

1. Click  on the Accessories caption bar. 

The Add New Accessory dialog box displays. 

2. Select Accessories/Components. 

3. Select the appropriate component type you 
want to add. 

4. Click OK. 

The accessories are assigned to the 
component and displayed in the Accessories 
pane. 

5. Click  to expand the newly added accessories 
menu. 

6. Enter the required data in the appropriate text 
box. 

 
 

Save Accessories 

Save the newly added accessories to the 
component. 

1. Click  on the Accessories caption bar. 

The Save to Library dialog box displays. 

2. Click OK. 

The new accessories are saved. 

 
Add New Accessory window 

 
Save to HyDraw Library message box 

 
Accessories section 

  



 

VEST, Inc. HyDraw® CAD 2019 99 

 

Delete Accessories 

1. Select the accessory you want to remove.  

2. Click  on the Accessories caption bar to 
delete the accessory. 

The accessory is deleted from the 
component. 

 

 
Accessories deleted from library 
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8. Documents 

Documents section displays the documents linked 
with the selected component model. You can delete 
and link documents from library. 

• Click  on the Documents caption bar to 
delete the linked document. 

• Click  Select from library to link new 
document to the selected component model. 

 

  
Documents Section 
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9. CAD Files 

The CAD Files section displays the CAD files linked 
with the selected component model. You can delete 
and link CAD files from the library. 

• Click  on the CAD Files caption bar to delete 
the linked CAD files. 

• Click   Select from library to link new CAD 
files to the selected component model. 

 

 
CAD File Section 
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27. System Properties 
When you open a schematic in the HyDraw® CAD, the System tab page displays the assigned properties of the selected system in the drawing.  
Add new accessories to the system and save in the library. 

1. Components  

The Components section displays the model 
codes of all the components in the circuit.  

Select the Item ID to highlight the 
corresponding component in the drawing. 

2. External Ports  

The External Ports section displays the ID 
and the size of all external ports in the 
circuit. 

Select the Item ID to highlight the 
corresponding external port in the drawing. 

3. Envelopes 

The Envelopes section displays the ID and 
the description of all envelopes in the circuit. 

Select the Item ID to highlight the 
corresponding envelope in the drawing. 

4. Accessories 

The Accessories section displays the details 
of accessories assigned with the circuit. 

5. Sub-Systems 

The Sub-Systems section displays the model 
codes of all sub-systems in the circuit. 

Select the Item ID to highlight the 
corresponding sub-system in the drawing. 

 

 
Schematic 

 
System tab page 
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28. Edit Properties 
Edit various properties of a symbol, external port, envelope line, connection line and sub-system. 
It displays the HyDraw® Property Manager, where the properties can be added and modified. 

1. Click Circuit > Edit  on the HyDraw CAD ribbon menu. 

The HyDraw Property Manager window displays. 

2. Edit the required properties of a symbol. 

3. The Display Setting can display multiple properties,  
if already defined in the Library Manager. 

 
HyDraw Property Manager - Display Settings 

 
 

 
Cylinder displayed with multiple properties 

 
HyDraw Property Manager 
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29. Copy Properties 
Copy component data, design requirements, accessories and linked data properties from one component symbol to another component symbol of the same category.  
Copy the properties of external ports and envelope data. 
Also copy sub-system data, design requirements, accessories and linked data properties from one sub-system to another sub-system of the same category. 

1. Click  on the HyDraw® CAD ribbon menu.  

The Select Source Symbol prompt displays. 

2. Select the source symbol. 

The Select Destination Symbols prompt displays. 

3. Select a single or multiple destination symbols. 

4. After completion of selection, press the Enter key.  

The Copy Property dialog box displays. 

5. Select the required design requirements, if you want to 
copy from the Design requirements checklist box. 

6. Select the Design Notes checkbox, if you want to copy 
the design notes to the destination symbol. 

7. Select the Include accessories checkbox, if you want to 
copy the accessories to the destination symbol. 

8. Select the Include Linked Documents and Linked CAD 
Files checkbox, if you want to copy the linked Documents 
and CAD Files to the destination symbol. 

9. Click Ok. 

The properties are copied to the destination 
symbol(s). 

 

 
Copy Properties 
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30. Refresh Properties 
Update the property values of sub-systems & components from HyDraw® Library. 

1. Click Circuit >  on the HyDraw CAD ribbon 
menu. 

The Select symbols prompt displays. 

2. Select single or multiple symbols.  

3. After completion of selection, press the Enter 
key. 

The Specify Items Included [Sub-Systems & 
Components/ Accessories/ Include All/ More 
Options] <Include All> prompt displays. 

Sub-Systems & Components further prompts, 
Include Child Items [Yes No] <Yes>. 

4. Specify the items to be refreshed. 

The Refresh Properties dialog box displays.  

5. Select individual properties to Refresh or Select 
All. 

6. Click OK. 

The Update message box displays. 

 

        
Refresh Properties – Specify Items                               Refresh properties – Properties Selection 

 

 
Successful Update message 
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31. Update Property List 
Update the properties of the Sub-systems & components, external ports, connection lines and accessories from the HyDraw® Library. 

1. Click Circuit >  on the HyDraw CAD ribbon menu. 

The Select symbols and connections prompt displays. 

2. Select single or multiple symbols, external ports, 
connection lines.  
After completion of selection, press the Enter key. 

The Specify Items Included [Sub-Systems & 
Components/ Accessories/ Include All/ More Options] 
<Include All> prompt displays. 

Sub-Systems & Components further prompts, 
     Include Child Items [Yes No] <Yes>. 

More Options further Prompts, 
     Include Components [Yes No] <Yes>. 
     Include Component Accessories [Yes No] <Yes>. 
     Include System Accessories [Yes No] <Yes>. 

3. Select the required option. 

The Update Properties List dialog box displays. 

4. Select the items to be included: 
   -  Add new model and design properties 
   -  Add new display formats 
   -  Update property and display format definitions 
   -  Delete unused properties and display formats 

5. Click Update.  

The Update Property List message box displays the 
status. 

6. Click OK to apply and exit. 

 

         
 Update Properties – Specify Items                                    Update Properties List 

 

   
  Update Status 
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32. Purge Properties 
Clear the properties values of a symbol. 

1. Click Circuit > Edit > Purge on the HyDraw® CAD ribbon 
menu. 

The Select Symbols prompt displays. 

2. Select single or multiple symbols.  
After the completion of selection, press the Enter key. 

The Specify items included [Sub-Systems & 
Components/Accessories/Include all/More options] 
<Include All> prompt displays. 

Sub-Systems & Components further prompts, 

Include Child Items [Yes No] <Yes>. 

More Options further Prompts, 

Include Components [Yes No] <Yes>. 

Include Component Accessories [Yes No] <Yes>. 

Include System Accessories [Yes No] <Yes>. 

3. Select the required option. 

The Purge Properties dialog box displays. 

4. Select the properties that are to be purged and Click OK. 

A warning message box displays. 

5. Click OK to continue  
or 
Click Cancel to exit. 

The selected properties are purged. 

 

                        
Purge Property Sub Menu                      Purge Properties dialog box 

 
 

 
Warning message box 
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HyDraw Property Manager before purge property 

 
HyDraw Property Manager after purge property 
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33. Purge Price Data 
Clear the price data values in the Drawing. 

1. Click Circuit > Edit > Purge Price Data on the HyDraw® 
CAD ribbon menu. 

The components in the schematic are selected 
automatically. 

The Purge Price Data warning message box displays, 
indicating that the price data will be removed 
permanently from all the components in the drawing. 

2. Select Include child items, if you want to remove the 
price data from the sub-system child items. 

3. Click OK, if you want to continue.  

On completion, prompts a message - Price data 
removed successfully.  

4. Click OK. 

 

 

Note: 

Save the schematic with a different file name and/or location 
before removing price information for your convenience and 
future reference. 

 
Purge Price sub menu 

 

 
Purge Price Data warning box 
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34. Edit Solenoid Information 
Edit the Solenoid ID of the selected symbol and function in the drawing. It does not affect the master symbol in the HyDraw® library. 

1. Select a valid HyDraw directional control  
valve symbol with the solenoid name. 

2. Click Circuit > Solenoid Info  on the HyDraw CAD 
ribbon menu. 

The Edit Solenoid Information dialog box displays. 

3. In the Solenoid ID column, edit the ID, if already 
available, or enter a new ID. 

The Show check box changes the visibility of the ID 
and function for the selected symbol.  

4. In the Available functions section,  
enter the Function name and click the Add button.  

The Update button allows editing the existing function. 

• Select the solenoid name. 

• Select the function. 

• Click the Add selected function button. 

• The selected function is added to the selected 
solenoid name. 

5. Click OK to close the window and to enable changes to 
take effect. 

 
Note: 

1. Changes affect only the symbol in the drawing and not 
the master symbol in the HyDraw Library. 

2. Solenoid IDs must be Unique to create Solenoid 
Actuation Chart, without Item ID. 

 
Opened symbol stencil for edit 

 

 
             Symbol before edit                                                Symbol after edit 
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35. Update from Excel 
Fetch the data from the ERP data file in the Excel format. 

1. Click Circuit >  on the HyDraw® CAD ribbon menu. 

The Select Symbols prompt displays 

2. Select single or multiple symbols.  
After the completion of selection, press the Enter key. 

The Specify items included [Sub-Systems & 
Components/Accessories/Include all/More options] 
<Include All> prompt displays. 

Sub-Systems & Components further prompt: 
Include Child Items [Yes No] <Yes>. 

More Options further Prompt: 
Include Components [Yes No] <Yes>. 
Include Component Accessories [Yes No] <Yes>. 
Include System Accessories [Yes No] <Yes>. 

3. Select the required option. 

The Update from Excel dialog box displays. 
The columns get populated with the matching Model 
codes values. 
Partially matching Model Codes are displayed with 
the Select link. 

4. Click the Select link. 

The Select Model dialog box displays. 

5. Select the available Model Code, as required. 

6. Click OK. 

The highlighted cells indicate the matching values 
with the selected sub-systems, components and 
accessories. 

 

 
Update from Excel  

  
Select Model dialog box 

  



 

VEST, Inc. HyDraw® CAD 2019 112 

 

7. Click Update to update the selected row.  

8. Click Update All to update all the rows in the drawing. 

The selected models are updated to the selected 
symbols properties 
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Modify Symbols 
 
             

 
 

36 Move Symbol 

37 Align Symbols  

38 Rotate Symbols  

39 Flip Symbols 

40 Align Symbol Ports 

41 Align External Port Names 

42 Edit Symbol Port 

43 Edit in Place 

44 Delete a Symbol 

45 Stack Symbols 

46 Show/Hide Port Names 

47 Show/Hide Design Notes 

48 Edit Design Notes 

49 Edit Jumping Reference 

50 Find Jumping Reference 
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36. Move Symbol 
Move a symbol from one point to another in the drawing. 

1. Click Circuit > Move  on the HyDraw® CAD 
ribbon menu.  

The Select Symbol to Move prompt displays. 
 

2. Select the symbol. 

The Specify Base point or [Displacement] 
<Displacement> prompt displays. 
 

3. Specify the base point of the symbol. 

The Specify second point prompt displays. 
 

4. Specify the second point. 

The symbol is moved to the new location. 

 

 
Move Symbol 
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37. Align Symbols 
Align multiple symbols with another symbol, horizontally or vertically, from left, right, or middle. 

1. Click Circuit > Align Symbols  on the 
HyDraw® CAD ribbon menu.  

The Select Symbols to Move prompt displays. 

2. Select a single symbol or multiple symbols.  
After completion of selection, press the Enter 
key. 

The Select Symbol to Align With prompt 
displays. 

3. Select the symbol. 

The Align [Tops/Middles/ Bottoms/ Lefts/ 
Centers/ Rights] prompt displays. 

4. Select the required alignment and press the 
Enter key. 

The symbols get aligned with the selected 
symbol accordingly. 

                          
Symbols aligned from bottom           Symbols aligned from top           Symbols aligned from top 

 
 

                                                            
Symbols aligned from right             Symbols aligned from left            Symbols aligned from middle 
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38. Rotate Symbols 
Rotate a symbol, 90 degrees to its left or right.  
The associated text is constrained to remain horizontal.  

1. Rotate Left 

1. Click Circuit > Rotate Left  on the HyDraw® CAD 
ribbon menu.  

The Select Symbols prompt displays. 
 

2. Select a single or multiple symbol. 
After completion of selection, press the Enter key. 

The symbol rotates 90 degrees to its left. 

 

                
Select a symbol                Rotate symbol to the left 

 
2. Rotate Right 

1. Click Circuit > Rotate Right  on the HyDraw CAD 
ribbon menu.  

The Select Symbols prompt displays. 
 

2. Select a single or multiple symbol. 
After completion of selection, press the Enter key. 

The symbol rotates 90 degrees to its right. 

 

 
Rotate symbol to the right 
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39. Flip Symbols 
Flip a symbol horizontally or vertically. The associated text is constrained to remain horizontal.  
 

1. Flip Horizontal 

1. Click Circuit >  Flip Horizontal from the Modify Symbol option on the 
HyDraw® CAD ribbon menu.  

The Select Symbols command displays. 
 

2. Select a single or multiple symbol. 
After completion of selection, press the Enter key. 

The symbol flips horizontally. 

 

 
2. Flip Vertical 

1. Click Circuit >  Flip Vertical from the Modify Symbol option on the 
HyDraw CAD ribbon menu.  

The Select Symbols command displays. 
 

2. Select a single or multiple symbol. 
After completion of selection, press the Enter key. 

The symbol flips vertically. 

 

                      

 

                         
Symbol inserted in the drawing          Symbol after horizontal flip  Symbol inserted in the drawing             Symbol after vertical flip 
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40. Align Symbol Ports 
Align ports of different symbols horizontally or vertically.  

1. Click Circuit > Align Symbol Ports  on the 
HyDraw® CAD ribbon menu. 

The Select Symbols Port to Move prompt 
displays.  
 

2. Select a port by clicking on the red cross or the 
port name. 

The Select Symbol Port to Align With prompt 
displays. 
 

3. Select a port by clicking on the red cross or the 
port name. 

The Align on [X-axis/ Y-axis] command 
displays on the command window.  
 

4. Enter the appropriate axis and press the Enter 
key. 

The symbols are aligned with reference to 
their ports. 

 

Note: 

When aligning external ports (that are aligned with 
the envelope) to symbol ports, in some cases the 
envelope line may pass through the external ports.  
In such cases, manually adjust the envelope line. 

 
Before 

 

 
After 

Symbol ports aligned vertically 

 
Before 

 
 
 

 
After 

 

Symbol ports aligned horizontally 
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41. Align External Port Names 
Align port names of all the selected ports horizontally or vertically along the envelope line. 

1. Click Circuit > Align External Port 

Names  on the HyDraw® CAD ribbon 
menu.  

The Select System Ports prompt 
displays. 
 

2. Select ports to align port names.  
After completion of selection, press the 
Enter key. 

The symbol-port names get aligned. 
 

In this selection, the left and bottom 
port name is taken as reference and 
all other system port names are 
aligned in a single line parallel to 
the envelope. 

 

 
                              Selected system ports 

 
 

 
                        System port names aligned 
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42. Edit Symbol Port 
Edit the port name of the selected symbol in the drawing.  
It does not affect the master symbol in the HyDraw® library.  

1. Click Circuit > Edit Symbol Port   on 
the HyDraw CAD ribbon menu. 

The Select Symbol prompt displays. 

2. Select the symbol port to be renamed. 

The Edit Port dialog box displays. 

3. Type the new name in the Name 
column and the optional Other Name 
column. 

4. To delete the port, click . 

5. Select Name/Other Name in the 
Display option. 

6. Click OK. 

The name or the other name of the 
port displays with the symbol. 

If both the names are selected, then 
dual port names are displayed. 

 

Note: 

The changes affect only the symbol in the 
drawing and not the master symbol in the 
HyDraw Library. 

 

 
Edit Port Name 

 

 

Symbol with unedited ports                             Symbol with Dual port names 
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43. Edit in Place 

1. Symbol 

Edit the selected symbol in the drawing.  
It does not affect the master symbol in the HyDraw® library. 

1. Click Circuit > Edit symbol  on the 
HyDraw CAD ribbon menu. 

The Select Symbol to Edit prompt 
displays. 

2. Select the symbol from the drawing 
you want to edit. 

The symbol opens in the Block 
Editor. 

3. Edit the symbol using the Block 
Authoring Palettes. 

4. Click Close Block Editor to close the 
window after you make the changes. 

 
Note: 

The changes affect only the symbol in the 
drawing and not the master symbol in the 
HyDraw Library. 

  
Symbol opens in Block Editor window 
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2. Sub-System 

Edit the selected sub-system in the drawing. It does not affect the master sub-system in the HyDraw® library. 

1. Click Circuit > Edit symbol  
on the HyDraw CAD ribbon 
menu. 

The Select Symbol to Edit 
prompt displays. 

2. Select the sub-system from 
the drawing you want to edit. 

The Sub-System opens in the 
Edit in Place mode. 

The Sub-System is available for 
editing and the schematic is 
grayed out in the drawing. 

Edit Reference: 

Save Changes: 

Click Save Changes to save the 
modifications. 

Discard Changes: 

Click Discard Changes to cancel the 
modifications. 

Add to Working Set: 

Click Add to Working Set to include 
more items to the sub-system. 

Remove from Working Set: 

Click Remove from Working Set to 
remove the items from the sub-
system. 

 

 
Sub-System opens in Edit in Place mode 
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44. Delete a Symbol 
Delete a symbol from the drawing. 

1. Click Circuit> Delete  on the HyDraw® CAD 
ribbon menu. 

The Select Symbols prompt displays. 
 

2. Select a single symbol or multiple symbols to 
delete.  
After completion of selection, press the Enter 
key. 

The selected symbols and the connections 
are deleted. 

 

 
Circuit Before Deleting a Symbol 

  

 
Circuit After Deleting a Symbol 
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45. Stack Symbols 
Stack symbols horizontally or vertically. 
 

1. Click Circuit > Stack  on the HyDraw® CAD 
ribbon menu. 

The Select Symbols to Stack prompt displays. 

2. Select multiple symbols to stack.  
After completion of selection, press the Enter 
key. 

The Stack direction [Up/Down/Right/Left] 
<Up>:  prompt displays. 
 

3. Select the direction. 

The symbols are stacked, accordingly. 

 
 
Note: 

• Port ‘P’ is the default alignment guide. 

• If there is no ‘P’ port, then port ‘X’ is used (e.g. 
Slip-in cover). 
In all other cases, Symbol Alignment box center is 
used to align the symbols. 

        
Symbols to Stack                                                   Symbols after Stacking 
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46. Show/Hide Port Names 
Toggle between ON/OFF name of the ports in the drawing. 

1. Click System > Port Name  on the HyDraw® 
CAD ribbon menu. 

The Select Symbols prompt displays. 
 

2. Select a single symbol or multiple symbols.  
After completion of selection, press the Enter 
key. 

Enter Option [Show/Hide] <Hide>:  
prompt displays. 
 

3. Enter the required option. 

Show: The names of the ports in the symbols 
are shown. 

Hide: The names of the ports in the symbols 
are hidden. 

Toggle between ON/OFF names of the ports 
in the drawing. 

 

 
Symbol before                                              Symbol after hiding port name 
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47. Show/Hide Design Notes 
Toggle between ON/OFF design notes icon in the drawing. 

Click System > Design Notes on the HyDraw® CAD 
ribbon menu. 

All the Design notes icons of the drawing will be 
hidden or shown per its original status 
(Toggle action). 
 

Note: 

You can edit Design notes by double clicking the icon. 

 

             
Symbol showing the Design Notes icon                                         Symbol with the hidden Design Notes icon 
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48. Edit Design Notes 
Edit the design notes of the symbol in the drawing. The changes do not affect the master symbol in the HyDraw® library 

1. Double click  the Design notes icon of the 
symbol in the drawing. 

The edit design note text box displays.  
By default, the design notes icon will be in 
the Read only mode. 

2. Click the edit button  to open in the writable 
mode.  

3. Edit the text and click  to save. 

4. Click  button to close.     
Symbol with Design Notes 

 
 

  
Edit Design Note 
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49. Edit Jumping Reference 
Modify the jumping reference details in the drawing.  

1. Click Circuit > Edit Jumping Reference on the 
HyDraw® CAD ribbon menu. 
Or Double click to edit the required jumping 
reference. 

The Select Jumping Reference prompt displays. 

2. Select the required jumping reference to modify. 

The Jumping Reference dialog box displays. 

3. Enter the required Name of jumping reference. 

4. Select the required Circuit type from the drop-down 
list,  

If the Use circuit type option is selected in the 
HyDraw Options > Connection > Jumping Reference. 

5. Enter the required Destination sheet. 

6. Enter the required Grid square, 

If the Use grid square option is selected in the 
HyDraw Options > Connection > Jumping Reference. 

7. Click OK. 

The jumping reference is automatically inserted 
vertically or horizontally on the unconnected end 
of a connection line with modified details. 

Note:  

You cannot modify jumping reference name, when more 
than one pair of same name exists in the drawing. 

 

 

Edit Jumping Reference dialog 

 
 

 
Before modifications of jumping reference 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
After modifications of jumping reference 
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50. Find Jumping Reference 
Locates the matching pair of jumping reference in the drawing. 

1. Click Circuit > Find Jumping Reference on 
the HyDraw® CAD ribbon menu. 

The Select Jumping Reference prompt 
displays. 

2. Select the jumping reference which you want to 
locate a matching pair in the drawing. 

HyDraw automatically zooms to display the 
matching pair of jumping reference in the 
drawing. 

A warning message box displays, when 
matching pair is not available in the drawing. 

 
Locate matching pair of jumping reference 
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51. Change Text Height 
Change the text height of the displayed Item ID and other parameters of the selected symbols. 

1. Click System  >  Height  
on the HyDraw® CAD ribbon menu.  

The Select Symbols and connections prompt 
displays on the command window. 

2. Select a single symbol or multiple symbols, and 
connections.  
After completion of selection, press the Enter 
key. 

The Specify items to update [Item ID/ 
Property Text/ Solenoid Text/ Hose ID/ All] < 
All> prompt displays. 

3. Enter the items to be updated and press the 
Enter key. 

4. Select Item ID/ property text/ solenoid text/ 
Hose ID/ All: 

The Change text height to <value>: prompt 
displays. 

5. Enter the text height value and press the Enter 
key. 

The height of the text is changed. 

 

Note:  Change Text Height dialog box will display 
when Show options on Command Line option is 
Unselected in HyDraw Options > Misc > Command 
Options. 

 
Change Text Height 
 
 
 

 
Text height changed (Before and After) 
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52. Rotate Property Text 
Rotate the displayed text of the selected symbols and connections. 

1. Click System > Rotate  on the HyDraw® CAD 
ribbon menu. 

The Select Symbols and Connections prompt 
displays. 

2. Select a single symbol or multiple symbols and 
connections.  
After completion of selection, 
press the Enter key. 

The Rotate Property Text dialog box displays. 

3. Select the property you want to rotate. 

4. Click Rotate Left  

The Property Text rotates 90 degrees to its 
left. 

5. Click Rotate Right  

The Property Text rotates 90 degrees to its 
right.  

6. Click OK. 

The property of the text is rotated.  

 
Rotate Property Text dialog box 

 
 
 

 
Property text rotated 

  



 

VEST, Inc. HyDraw® CAD 2019 133 

 

53. Show/Hide Properties 
The properties toggle between display or hide in the drawing. 

1. Click System  >  Properties   
on the HyDraw® CAD ribbon menu. 

The Select symbols and connections prompt 
displays. 
 

2. Select a single or multiple symbols, external 
ports, connection lines  
after completion of selection, press the Enter 
key.  

The Show/Hide Properties dialog box 
displays. 
 

3. Select the properties in the Sub-Systems & 
Components section, External Ports section and 
Connections section. 

4. Click OK to apply and exit. 

 

 
Show/Hide Property dialog box 

 
 

 
Hiding a Property 
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54. Reassign Item ID 
Reassign the Item IDs and Assembly IDs of all symbols in the circuit after modification. 

1. Click System >  on the HyDraw® CAD ribbon menu. 

The Select Symbols prompt displays. 

2. Select a single symbol or multiple symbols.  
After completion of selection, press the Enter key. 

The Reassign Item ID dialog box displays. 

3. Enter the starting value of the Item ID. 

4. Enter the Assembly ID. 
Select the Reassign Only Assembly ID check box, if you want to 
reassign only assembly ID. 

5. Select the Include child items checkbox to include sub-systems child 
items. 

6. Choose the Balloon type for components, accessories, sub-systems 
and Hoses. 

Select the checkbox, if you want to use the current balloon type. 

7. Select the appropriate option for Items included. 

• Select the Sub-Systems & Components checkbox to include all sub-
systems and components. 

• Select the Component accessories checkbox to include all 
component accessories. 

• Select the System accessories checkbox to include all system 
accessories. 

• Deselect the Hoses checkbox to exclude hoses. 

8. Click OK.  

9. For ISO 1219 Scheme, enter the Installation Code, Circuit Number and 
Medium Code. 

 
Reassign Item ID 

 
Reassign Item ID – ISO 1219 Scheme 
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55. Reassign Hose ID 
Reassign the Hose IDs of all symbols in the circuit after modification. 

1. Click System >  on the HyDraw® CAD ribbon 
menu. 

The Select Symbols prompt displays. 

2. Select a single symbol or multiple symbols. Only 
hoses symbols will be included. 
After completion of selection, press the Enter 
key. 

The Reassign Hose ID dialog box displays. 

3. Enter the starting value of the Hose ID. 

4. Enter the Prefix. 

5. Choose the Balloon type. 

Select the checkbox, if you want to use the 
current balloon type. 

6. Click OK.  

7. For ISO 1219 Scheme, enter the Installation 
Code, Circuit Number and Medium Code. 

 
Reassign Hose ID 

 

 
Reassign Hose ID – ISO 1219 Scheme 
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56. Update Balloons 
Update balloons of selected symbols or schematic.  
This affects the type of balloons. 

1. Click System > Balloon  
 on the HyDraw® CAD ribbon menu.  

The Select Symbols prompt displays. 

2. Select a single symbol or multiple symbols.  
After completion of selection, press the Enter key. 

The Specify Balloon type prompts, 
[Circle/Ellipse/Rectangle/Rounded 
rectangle/Hexagon/None/Use current balloon type] 

Update Balloon further prompts,  

Do you want to use different balloon style for sub-
systems [Yes No] <Yes> 

The Specify Balloon type further prompts, 
[Circle/Ellipse/Rectangle/Rounded 
rectangle/Hexagon/None/Use current balloon type] 

Update Balloon further prompts, 

Include child items [Yes No] <Yes> 

The Specify accessory balloon type prompts, 
[Circle/Ellipse/Rectangle/Rounded 
rectangle/Hexagon/None/Use current balloon type] 

The selected balloon types are recreated for the 
components, Accessories, Hoses, sub-systems and 
sub-system child items. 

 
Update Balloon dialog 

 

 
Changing Balloon from Circle to Rounded rectangle 
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57. Add New Display Format 
Add a new display format of selected symbols and connections.  

1. Click System > Display Format on the 
HyDraw® CAD ribbon menu. 

The Select Symbols and Connections prompt 
displays. 

2. Select a single symbol or multiple symbols or 
connections.  
After completion of selection, press the Enter 
key. 

The Add New Display format dialog box 
displays. 

3. Enter the name of the display format. 

4. Click  on Property1 section to select property 
to display in the required format. 

The Select Property dialog box displays. 

5. Select property and click OK. 

6. Enter prefix and suffix values to be displayed. 

7. Select the Display unit check box to display 
units. 

8. Repeat step 4 to select more than one and up to 
three properties to display in this display 
format. 

9. Click Add. 

                        
Add New Display Format dialog box                                                     Select Property 
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58. Create and Insert Parts List 
Create a list of components, envelope, sub-systems and accessories for a schematic. 

1. Insert Parts List  

1. Click System > Parts List  on the HyDraw® CAD ribbon menu.  

The Select Symbols prompt displays. 

2. Select a single or multiple symbol.  
After completion of the selection, press the Enter key. 

The Create Parts List dialog box displays. 

3. Select the items to be included by clicking the required checkboxes, 

Sub-Systems & Components: 

Include all components & sub-systems in the Parts list. 

Component accessories: 

Include all component accessories in the Parts list. 

System accessories: 

Include all system accessories in the Parts list. 

Group identical items: 

Group all the identical items in the Parts list. 

Include child items: 

Include all the sub-system child items in the parts list. 

Unselect the Hoses option to exclude hoses from the selection. 

Group identical items work only for 1A, 1B, 2A, 2B…, 1,1,2, 2,…,  
1.1,1.2,2.1,2.2…, and 1-1,1-2,2-1,2-2… numbering scheme. 

4. Select the required format. 

The default format is applied, if nothing is selected. 

 
Create Parts List dialog box 

 
Create Parts List dialog box 
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5. Click Next 

The Create Parts List dialog box displays the details of the Parts 
properties. 

6. Click   or  to move the selected item row up or down, 
respectively. 

7. Click  to delete the selected item from the list. 

8. Double Click on Blank Cell to Edit Parts List. 

Add missing property values of Components in Parts List. 

9. Click Update after Editing Parts List. 

10. Click Yes. 

Updates values in Model Data of the Component in Parts List and 
HyDraw Property Manager. 

11. Click Insert to Drawing to insert the Parts list as a separate list in the 
drawing. 

12. Select an area to create Parts List.  

13. Specify the first corner. 

The Specify opposite corner: prompt displays. 

14. Specify the opposite corner. 

The Parts list is inserted into the drawing in a tabular form. 

15. To save the Parts list as an Excel sheet,  
click Export to Excel. 

The Parts List is saved in the Excel format. 

Note: 

• Parts List groups the components based on grouped Item ID and Model 
Code.  

• If Part List does not contain Model Code, the components are grouped 
based on the identical properties. 

 
Parts List inserted in the drawing 
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2. Auto Update Parts List 

1. Insert Parts List in the drawing. 

2. Select a symbol and update Model Data value from HyDraw Property 
Manager. 

Update notification  displays for the Model in the existing Parts 
List with the modified cell value in Red color. 

3. Select and right-click the Part List table in the drawing. 

Context menu displays. 

4. Select Update Parts List. 

Existing Parts List displays the updated values. 

 
 

Parts List inserted in the drawing 

 
Update Parts List – Context Menu 

 
Updated Parts List in Drawing 
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3. Customize Parts List Format 

1. Click Circuit > Options… on the HyDraw® CAD ribbon menu. 

2. Click the Lists & Charts tab and select Parts List. 

The Parts List formatting box displays inside the tab. 

3. To rename a selected format,  

type the new name in the text box and click . 
 

4. To add a new format,  

type the new name in the text box and click . 
 

5. To delete a selected format, click  below the textbox. 

The Configure Columns section enables to edit Display Name, 
Alignment, and Width of the columns. 

6. Click Add. 

The Select Parts List Columns dialog box displays. 

7. Select the required Model properties or Design requirements 
checkbox. 

8. Click Browse and select the Excel template. 

9. Set the Start Column and the Start Row of the Parts list to be inserted 
into the Excel template. 

10. Click OK. 

The properties of the selected items are displayed in the Parts List 
formatting box in the Configure columns section. 

Same properties are displayed in the tabular form Parts list,  
when creating Parts list in the drawing. 

 
Lists & Chart Tab: Parts List 

 
Select Parts List Columns dialog box 
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59. Create and Insert Ports List 
Create a list of external ports used in the circuit. You can insert this list in the drawing. The tabular list exhibit details about the external ports. 

1. Insert Ports List  

1. Click System > Ports List  on the HyDraw® CAD ribbon menu.  

The Select Ports prompt displays. 

2. Select a single or multiple port. After the completion of selection, press the Enter key. 

The Create Ports List dialog box displays. 

3. Select the Group identical items checkbox to group all identical items in the Ports list. 

i. Select the required format.  
If no format is selected, then the default format is applied. 

4. Click Next to display the Create Ports List dialog box. 

The Create Ports List dialog box displays the details of the port properties. 

5. Click  or  to move the selected item row up or down, respectively. 

6. Click  to delete the selected port from the list. 

7. Click Insert to Drawing to insert the Ports list as a separate list in the drawing. 

8. Select an area to create the Ports List.  

Specify first corner: prompt displays. 

9. Specify the first corner. 

The Specify opposite corner: prompt displays. 

10. Specify the opposite corner.  

The Ports list is inserted into the drawing in a tabular form. 

11. To save the Ports list as an Excel sheet,  
click Export to Excel. 

The Ports List is saved in the Excel format. 

 
Create Ports List dialog box 

 
Create Ports List 

 
Ports List in the drawing 
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2. Customize Ports List Format 

1. Click Circuit >  Options… on the HyDraw® CAD 
ribbon menu. 

2. Click the Lists & Charts tab and select Ports List. 

The Ports list formatting box displays inside 
the tab. 

3. To rename a selected format,  

type the new name in the textbox and click . 
4. To add a new format,  

type the new name in the textbox and click  
below the text box. 

5. To delete a selected format, click . 

The Configure Columns section enables 
editing of the Display Name, Alignment,  
and Width of the columns. 

6. Click . 

The Select Ports List columns dialog box 
displays. 

7. Select the required properties. 

8. Click OK. 

The properties of the selected item are 
displayed in the Ports List formatting box in 
the Configure columns section. 

Same properties are displayed in the tabular 
form Ports list,  
when creating the Ports list in the drawing. 

 
Ports List tab 

 
Select Ports List columns 

  



 

VEST, Inc. HyDraw® CAD 2019 145 

 

60. Create and Insert Hose List 
Create a list of hoses used in the circuit. You can insert this list in the drawing. The tabular list exhibit details about the hoses. 

 Insert Hose List  

1. Click System > Hose List  on the HyDraw® CAD ribbon menu.  

The Select Hoses prompt displays. 

2. Select a single or multiple hose. After the completion of selection, press the Enter key. 

The Create Hoses List dialog box displays. 

3. Select the Group identical items checkbox to group all identical items in the Hose list. 

Group identical items works only for the given numbering scheme in Option. 

4. Select the required format. If no format is selected, then the default format is applied. 

5. Click Next to display the Create Hose List dialog box. 

The Create Hose List dialog box displays the details of the hoses properties. 

6. Click  or  to move the selected item row up or down, respectively. 

7. Click  to delete the selected hose from the list. 

8. Click Insert to Drawing to insert the hose list as a separate list in the drawing. 

9. Select an area to create the Hose List.  

Specify first corner: prompt displays. 

10. Specify the first corner. 

The Specify opposite corner: prompt displays. 

11. Specify the opposite corner.  

The Hose list is inserted into the drawing in a tabular form. 

12. To save the Hose list as an Excel sheet,  
click Export to Excel. 

The Hose List is saved in the Excel format. 

 
Create Hose List dialog box 

 
Create Hose List 

 
Hoses List in the drawing 
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 Customize Hose List Format 

1. Click Circuit > Options… on the HyDraw® CAD ribbon 
menu. 

2. Click the Lists & Charts tab and select Hose List. 

The Hose list formatting box displays inside the tab. 

3. To rename a selected format,  

type the new name in the textbox and click . 
4. To add a new format,  

type the new name in the textbox and click  below the 
text box. 

5. To delete a selected format, click . 

The Configure Columns section enables editing of the 
Display Name, Alignment, and Width of the columns. 

6. Click . 

The Select Hose List columns dialog box displays. 

7. Select the required properties. 

8. Click OK. 

The properties of the selected item are displayed in 
the Hose List formatting box in the Configure columns 
section. 

Same properties are displayed in the tabular form 
Hose list,  
when creating the Hose list in the drawing. 

 
List& Chart Tab - Hose List  

 
Select Hose List columns 
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61. Create Solenoid Actuation Chart 
Insert the Solenoid Actuation chart in the drawing. 

1. Click Circuit > Actuation  on the HyDraw® CAD ribbon menu.  

The Select Symbols prompt displays. 

2. Select a single or multiple symbol. After the completion of selection,  
press the Enter key. 

The Use Item ID [Yes No] <Yes> prompt displays. 

3. Press Enter. 

The Solenoid Actuation Chart displays Function, Item ID-Solenoid ID, if 
applicable. 

4. Click the Update  button to update the function name. 

The Update Function dialog box displays. 

• Select the function to update. 

• Rename the function. 

• Click Update. 

• Click OK to display the changes in the Solenoid Actuation chart. 
 

5. Click  or  to move the selected item one row up or one row down, 
respectively. 

6. Click  to delete the selected function from the list. 

7. Click Export to Excel to save the Solenoid Actuation chart as an Excel file  
(.xls or .xlsx). 

8. Click Insert to Drawing to insert the Solenoid Actuation chart into the drawing. 

You can customize the Actuation List Format from HyDraw Option. 

Note: 

Solenoid IDs must be unique to create Solenoid Actuation Chart. 

 
Solenoid Actuation Chart – Grid View 

  
Update Function 

 
Solenoid Actuation Chart 
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62. Create and Insert Net List 
Create a list of networks (Net List) of components and external ports in the circuit.  
You can insert the Net list in the drawing. The tabular list exhibit details about the networks. 

1. Click System > Net List  on the HyDraw® CAD ribbon menu.  

The Select manifold prompt displays. 

2. Select the envelope line. After completion of selection, press the Enter key. 

The Create Net List box displays net name with the corresponding net items and status. 

3. Enter the Net Pressure for the whole net. 

This updates the pressure of all the symbols in the net. 

The Status column shows the accounted nets with and amended nets with  
indicating that the nets are amended and require recreation.  

By selecting a net on the Status column, the respective net is shown as hidden in the 
drawing. 
(In case of hidden connection lines at low zoom level, the hidden preview may not be 
visible. If the connection is not correct, red dots appear along the connection points.) 

4. Click Clear Error Flags to remove the error flags from the drawing. 

5. Click Recreate to return to create the Net list. 

6. Click Export to save the Net list as an Excel file (.xls or .xlsx). 

7. Click Insert to insert the Net list in the drawing. 

8. Select an area to create the Net list. 

The Specify first corner prompt displays. 

9. Specify the first corner. 

The Specify opposite corner: prompt displays. 

10. Specify the opposite corner.  

The Net list is inserted into the drawing. 

11. Click OK to exit or Click Cancel to cancel the Net list creation. 

 
Create Net List 

 
Net List 
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Note: 

• The individual symbols of Slip-Cartridge valve cover and Insert are 
combined with “&” and accepted as a single entity, when creating the 
Net list. 

• Orifice disc should be ignored, when creating the Net List. 

 

CAUTION! 

• Do not create more than one connection to the connection points. This 
may result in an incorrect Net list. 

• If OK is not pressed after net renaming, the corrections will be lost on 
recreation, with default net naming style. 

 

Note: 

You can customize the Net List Format from HyDraw Option. 

 

 
HyDraw Option-Net List  
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63. Create Design Note List 
Create Design notes list in the circuit and insert it in the drawing.  

1. Click System > Notes  on the HyDraw® CAD ribbon menu.  

The Select Symbols and Connections prompt displays. 

2. Select symbols and connections.  
After completion of selection, press the Enter key. 

The Create Design Note List box displays. 

3. Click  or  to move the selected item one row up or one row 
down, respectively. 

4. Click  to delete the selected function from the list. 

5. Click Export to save the Design Note list as an Excel file (.xls or .xlsx). 

6. Click Insert to insert the Design Note list in the drawing. 

7. Select an area to create the Design Note list. 

The Specify first corner prompt displays. 

8. Specify the first corner. 

The Specify opposite corner: prompt displays. 

9. Specify the opposite corner.  

The Design Notes list is inserted into the drawing. 

10. Click OK to exit or Click Cancel to cancel the Design Note list creation. 

You can customize the Design Note List Format from HyDraw Option. 

 

 
Create Design Notes List 

 
Design Notes List 

  



 

VEST, Inc. HyDraw® CAD 2019 151 

 

Collate Files 
 

 
  

64 Collate Documents 

65 Collate CAD Files 



 

VEST, Inc. HyDraw® CAD 2019 152 

 

64. Collate Documents 
Save documents linked to components, external ports, sub-systems, component accessories, and system accessories in the user-specified location. 

1. Click System > Collate Documents  from the Collate option on the 
HyDraw® CAD ribbon menu. 

The Select Symbols prompt displays. The Collate Documents dialog 
box displays. 

2. Select a single symbol or multiple symbols and then press the Enter 
key. 

The Specify items included [Sub-Systems & Components/External 
Ports/Accessories/Include all/More options] < Include All> prompt 
displays. 

Sub-Systems & Components further prompts, 

Include Child Items [Yes No] <Yes>. 

More Options further Prompts, 

Include Components [Yes No] <Yes>. 

Include Component Accessories [Yes No] <Yes>. 

Include System Accessories [Yes No] <Yes>. 

3. Select the required option and press the Enter key. 

The Collate Documents dialog box displays. 

4. Select the documents to be collated. 

5. Click OK. 

The Browse for Folder dialog box displays. 

6. Select the appropriate folder or click Make New Folder to create a 
new folder at the appropriate location for saving documents. 

 
Collate Documents dialog box 

 
Collate Documents: save files 
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65. Collate CAD Files 
Save the CAD files linked to the Components, External Ports, Sub-Systems, Component accessories, and system accessories in the user-specified location. 

1. Click System > Collate CAD Files   from the Collate option on the 
HyDraw® CAD ribbon menu.  

The Select Symbols prompt displays. 

2. Select a single symbol or multiple symbols and press the Enter key. 

The Specify items included [Components/External 
Ports/Accessories/Include all/More options] <Include All> prompt 
displays. 

Sub-Systems & Components further prompts, 

Include Child Items [Yes No] <Yes>. 

More Options further Prompts, 

Include Components [Yes No] <Yes>. 

Include Component Accessories [Yes No] <Yes>. 

Include System Accessories [Yes No] <Yes>. 

3. Select the required option and press the Enter key. 

The Collate CAD Files dialog box displays. 

4. Select the CAD files to be collated. 

5. Click OK. 

The Browse for Folder dialog box displays. 

6. Select the appropriate folder or click Make New Folder to create a 
new folder in the appropriate location for saving CAD files. 

 
Collate CAD Files dialog box 

 

 
Collate CAD Files: Save Files 
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Calculator 
 

 
 
 
 
 
 
 
 
  

66 Unit Converter 
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66. Unit Converter 
Convert value of any unit category from any unit to the other.  

1. Click System > Unit Converter from the 
Calculator option on the HyDraw® CAD ribbon 
menu.  

The Unit Converter dialog box displays. 

2. Select a unit category. 

3. Select the unit system in the From and To Units 
list box, per requirement. 

4. Specify the unit value in the From text box. 

Converted unit value appears in the To text 
box in the desired unit system. 

7. Click  to copy the To value to the clipboard. 

 

 
HyDraw Unit Converter 

 

 
Unit Converter dialog box 

  



 

VEST, Inc. HyDraw® CAD 2019 156 

 

MDTools Interface 
 

 
 
 
 
 

 
  

67 Export to MDTools 
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67. Export to MDTools 
Export a HyDraw® CAD created circuit as an XML, which can be readily opened in MDTools® for designing a manifold. 

 

1. Click System > MDTools on the HyDraw CAD 
ribbon menu.  

The Set Library Path dialog box displays. 

2. Click the Browse button to search the Library 
Path. 

The Browse for Folder dialog box displays. 

3. Browse and select the folder with MDTools 
library. 

4. Click OK to confirm the selection. 

The Select Symbols and Connections prompt 
displays. 

5. Select symbols and connections from the 
drawing.  

6. After completion of selection, press the Enter 
key. 

The Export to MDTools page loads. 

The data and the default values entered into 
HyDraw® are automatically read from the 
drawing. 

Note: 

Once specified, you cannot change the MDTools 
library path. 

 

 
Export to MDTools 
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Manifold Properties 

Configure following settings, 

• Material 

• Manifold Pressure 
 

Note:  

By default, Design Unit comes per unit selection 
in the HyDraw Options.  

 

Components and External Ports 

The Cavities section displays Component ID, Port 
Name, Linked CAD Files, Cavity, Engraving and 
Preferred Faces of the component.  

 
Configure following settings, 

• Engraving 

• Preferred Face 
 

The Nets section displays Nets and Net 
Information, Net Type and Net Pressure. 

 

Mounting Hole 

Select the required type mounting hole option. 

 

Export to MDTools 
 



 

VEST, Inc. HyDraw® CAD 2019 159 

 

Report 

Click Report > Schematic report dialog box displays. 

The Schematic report contains all extracted data 
from HyDraw Schematic. 

 

 
Schematic Reports  
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Export 

Click Export > Save Input File dialog box displays. 

Save the resulting XML file at the desired location. 

 
 
 
 
 
 
Note: 

• Information about CAD files, linked to 
components and accessories, is exported to 
MDTools, so that it automatically assembles the 
component models on the block. 

• The individual symbols of Slip-in cartridge cover 
and insert are combined with “&” and accepted 
as a single entity in the HyDraw Export to 
MDTools. 

• The individual symbols of Cartridge symbol and 
Orifice Disc are combined with “&” and accepted 
as a single entity in the HyDraw Export to 
MDTools. 

 

 
Save Input File dialog box 
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Convert 
 

 
 
 
 
 
 
 
 
 
 
  

68 Convert to HyDraw 

69 Update Drawing 



 

VEST, Inc. HyDraw® CAD 2019 162 

 

68. Convert to HyDraw 
Converts AutoCAD entities into HyDraw CAD entities. 

  

1. Click System  >  Convert to HyDraw on the 
HyDraw CAD ribbon menu. 

The Select Objects prompt displays. 

2. After completion of selection, press the Enter 
key. 

Convert to HyDraw dialog box displays. 

 

3. Select an Application. 

 
Convert to HyDraw dialog box 
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3. Convert to HyDraw Symbol 

 

4. Convert to HyDraw Connection 

  

1. Select a component type. 

2. Enter item ID. 

3. Insert Port 

• Enter port name. 

• Click Insert. 
The Specify Port Insertion point prompt 
displays. 

4. Click OK. 

The Specify Insertion point prompt displays. 

5. Specify the insertion point 

AutoCAD entities converted into HyDraw 
CAD entities. 

 

 
Before Convert to HyDraw Symbol 

 

 
After Convert to HyDraw Symbol 

1. Select a Connection type. 

2. Click OK. 

AutoCAD entities converted into HyDraw CAD 
entities. 

 

Before Convert to HyDraw Connection 

 

After Convert to HyDraw Connection 
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69. Update Drawing 
Update the Earlier Version connection line properties to the Current Version connection line properties. 

 

Click System > Update Drawing from 
Convert option on the HyDraw CAD ribbon 
menu. 

Connection line properties are 
automatically updated to current 
version line properties. 

 
Pipe and Tube connection data and 
design requirements are automatically 
restored to the connection lines with 
connector type, Pipe/Tube/Hose/Drill 
Hole. 

 
Update Drawing 
 

 
Before Update Drawing – Connection Properties 

 
 
 
 
 
 

 
After Update Drawing – Connection Properties 
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Check 
 

 
 
 
 
 
  

70 Schematic Check 
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70. Schematic Check 
Reports the components/external ports data error and connections error in the drawing. 
This feature enables you to check the drawing for: 
- Component/Port/Envelope missing data 
- Item ID/Port Name not specified 
- Duplicate Item ID/Port Name 
- Items not included in Parts list 
- Hanging connection 
- Overlapping connection 
- Validation of Connection 
- Self crossing line 
- Multiple connections from single port 

 

1. Click System > Schematic Check from Check 
option on the HyDraw CAD ribbon menu. 

The Schematic Check dialog box displays. 

 

2. Select the parameters you want to check. 

 

3. Select Zoom on selection, if you want to zoom 
into problem area on selecting error in the 
report. 

 

4. Click Check. 

HyDraw® checks the schematic drawing for 
the selected parameters and lists the error 
report in the dialog box. 

 
Schematic Check dialog box 
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Error Type 

Components: 

Model Code Missing: 
Model code is not available in the 
component. 

Item ID Missing: 
Item ID is not specified in the 
component. 

Duplicate Item ID: 
Multiple components having same Item 
ID in the drawing. 

Item not included in Parts List: 
Include in parts list option is unchecked 
in the HyDraw Property Manager for the 
component. 

Ports Not Connected: 
Component symbol Ports neither 
connected nor blocked. 

 

External Ports: 

Port Size Missing 
Port size is missing in the external port 
name. 

Duplicate Port Name 
Multiple external ports having same port 
name in the drawing. 

Ports Not Connected: 
Ports neither connected nor blocked. 
 

 

Connection Lines: 

Hanging Connection 
Connection line one end or both ends are 
unconnected. 

Overlapping Connections 
Two or more connection lines exist at same 
location. 

Self-Crossing Line 
One end of the connection line crossing the other 
end of the same connection line 

Multiple Connections from Single Port 
Multiple connection lines are connected to a 
single port. 

Connection Validation 
Potentially wrong connections with incorrect 
Connection Types in the drawing. 
 

Envelopes: 

Model Code Missing: 
Model code is not available in the Envelope. 

Item ID Missing: 
Item ID is not specified in the Envelope. 

Duplicate Item ID: 
Multiple Envelopes having same Item ID in the 
drawing. 

Item not included in Parts List: 
Include in parts list option is unchecked in the 
HyDraw Property Manager for the Envelope. 

 
Schematic Check Report 
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Title Block 
 

 
 
 
 
  

71 Insert Title Block 

72 Edit Title Block 
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71. Insert Title Block 
Insert a HyDraw Title block to the drawing. 

  

1. Click System > Insert Title Block on the 
HyDraw CAD ribbon menu. 

Insert Title Block dialog box displays. 

2. Select Sheet Size. 

3. Click OK and Exit. 

HyDraw Title Block inserted into the 
drawing. 

 
 

Note: 

By default, drawing units comes as per unit 
selection in the HyDraw Options. 

 
Insert Title Block dialog box 
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72. Edit Title Block 
Edit all properties in the Title block. 

 

1. Click System > Edit Title Block on the HyDraw 
CAD ribbon Menu. 

Edit Title Block dialog box displays. 

2. Select a property. 

3. Enter a value. 

4. Select Export, if required. 

The Save As dialog box displays. 

5. Enter an appropriate file name. 

6. Click Save. 

Title Block attributes saved as Text file. 

7. Click OK in Edit Title Block Dialog. 

Values updated in the inserted Title block. 
 

Import 

1. Click System > Edit Title Block on the HyDraw 
CAD ribbon menu. 

The Edit Title Block dialog box displays. 

2. Select Import. 

The Select File dialog box displays. 

3. Select the text file with Block attributes. 

4. Click Open. 

Property values updated in the dialog box. 

5. Click OK. 

Values updated in the inserted Title block. 

  

Edit Title Block dialog box  
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FluidPowerTools.com 
 

 
  

73 Data Access Settings 

74 Help for FluidPowerTools.com 

75 Internet Settings 
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73. Data Access Settings 
Select Manufacturer database to search components. 
 

1. Click Services > Data Access Settings on 
the FluidPowerTools section on the 
HyDraw® CAD ribbon menu. 

The FluidPowerTools.com Data 
Access Settings dialog box displays. 

 

2. Select the required Manufacturers 
from the list and click OK. 

 

 
Data Access Settings Menu Item 

 

 
Data Access Settings dialog box 
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74. Help for FluidPowerTools.com 
 

1. Subscription Information 

Know the HyDraw® version and subscription information. 

Click Services > Subscription Information on 
the FluidPowerTools section of the Services 
tab in the HyDraw CAD ribbon menu. 

The FluidPowerTools.com - Data Service 
information box displays. 

 

 
Help menu and submenu 

 

 
The FluidPowerTools.com Data Service 
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2. Component Data Available 

Navigate to FluidPowerTools.com, where you can see the component data of major Fluid Power manufacturers. 

Click Services > Component Data Available 
on the FluidPowerTools section of the 
HyDraw® CAD ribbon menu. 

 
The FluidPowerTools.com - Component Data 
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3. Terms of Usage 

Navigate to FluidPowerTools.com, where you can see the terms and conditions of using the services on FluidPowerTools.com 

Click Services > Terms of Usage on the 
FluidPowerTools section on the HyDraw® 
CAD ribbon menu. 

 
The FluidPowerTools.com Terms and Conditions, Disclaimer 
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4. Contact Info. 

Navigate to FluidPowerTools.com, where you can find the contact information of the VEST team. 

Click Services > Contact Info on the 
FluidPowerTools section on the HyDraw® CAD 
ribbon menu. 

 

 
The FluidPowerTools.com - Contact Info 
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75. Internet Settings 
Configure the Internet settings for FluidPowerTools.com. 

 

1. Click Services > Internet Settings on the 
Setup section of the Services tab on the 
HyDraw® CAD ribbon menu. 

The Internet Settings tab page 
displays. 

 

2. Configure the connection, per 
requirement. 

 

3. Click OK to apply and exit. 

 
HyDraw Options: Internet Settings 
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HyDraw CAD Help 
 
 

 
 
  

76 Help 

77 License Information 

78 About HyDraw 
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76. Help 
 

 
Help Command Menu and Sub menu 

 

 

HyDraw 

The HyDraw command opens the HyDraw® CAD 2019 Help 

 

2D Drafting 

The 2D Drafting command opens the 2D drafting help file for HyDraw CAD 2019. 

 

License Information 

The License Information command opens the HyDraw® CAD 2019 License. 

Details. Refer Ch.77 
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77. License Information 
HyDraw License Information displays - Version Number, Build number, License type, License key, License Status, Expiration Date, Serial number and Borrow details. 
 

Network License 

1. Click Help > Help > License Information. 

HyDraw CAD 2019 License Details dialog displays. 

 
Network License Details - Borrowed 

5. Click Return to release the Borrowed* Network License. 

License returned successfully message displays. 

 

6. Click OK. 

 
Note:  

• Borrow option available for Network License only. 

• Transfer option available for Standalone License only. 

Standalone License 

1. Click Help > Help > License Information. 

HyDraw CAD 2019 License Details dialog displays. 

 

Transfer License 

1. Click Transfer to switch the HyDraw Standalone License to a different 

computer/system. 

HyDraw CAD 2019 Authorization dialog displays. 

2. Click Next and Create Request. 

License Transfer warning displays. 

 
License Transfer Warning 

3. Click Yes.   

Transfer request is generated and prompts to save in an xml file.  

4. Attach Transfer Request file to an email and send it to support@VESTusa.com. 
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78. About HyDraw 
Displays product information. 

 
About HyDraw Menu item 

 

  
About HyDraw dialog box 
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Installation & Setup 
  

79 HyDraw CAD 2019 Installation  

80 Library Network Configuration 

81 Set Online Services (FPT) 

82 Build New Symbols 

83 Build External Port Symbols 

84 Build New Sub-Systems 

85 Manage HyDraw CAD Drawings through Vault 
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79. HyDraw CAD 2019 Installation 
The HyDraw® installation program installs HyDraw CAD 2019 on your computer. 

 

1. System Requirements:  

The system requirements are provided in the product documentation. 

Software 

• Microsoft Windows 10, Microsoft Windows 8.1 with Update KB2919355, Microsoft® Windows® 7 SP1(64-bit). 

• .Net Framework 4.6.  

• Microsoft Internet Explorer® 11.0 or later.  

• Adobe Reader 10 or higher. 

• Excel 2013* or higher. 

* Required only for exporting HyDraw data. 

Note: 
HyDraw CAD 2019 is compatible with 64-bit Operating System, If required, install 32/64-bit Office 2013/2016 on 64-bit Operating System. 

Hardware 

• Processor: 1 gigahertz (GHz) or faster 64-bit (x64) processor. 

• Memory: 8 GB RAM or more. 

• Display Resolution: 1360 x 768 (1920 x 1080 recommended) with True Color  

• Hard Disk: 6.0 GB free disk space  

 
Note: 

The minimum required configuration is listed above. It is recommended to use a higher hardware configuration for power users. 
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2. Software Installation 

1. Run the self-extracting exe, HyDraw CAD 2019.0.0.5 R x64 - EN 
Setup.exe/HyDraw CAD 2019.0.0.5 R x64 – IT from the 
downloaded installation and unzip.  

or  

Insert the HyDraw® CAD 2019 DVD into the DVD-ROM drive. 

If Auto Run is not set, then: 
a) On the Start menu, click Run. 
b) Browse to the Setup.exe program on the CD-ROM drive.  
c) Select Setup.exe and click Open. 
d) Click OK. 

 
The HyDraw CAD installation program dialog box displays. 

2. Click Install Products to install the HyDraw CAD application. 

3. Accept the License Agreement and click Next. 

The Software can be configured for both typical and custom 
installation. 

4. After Configuration, click Configuration Complete. 

5. Click Install. 

View the HyDraw CAD User Manual and the ReadMe file from 
the Documentation section, if required. 

6. Once complete, click Finish in the HyDraw CAD 2019 dialog box 
and Restart your computer for the changes to take effect. 

HyDraw CAD 2019 and HyDraw Library Manager 2019 are 
installed on the system and HyDraw CAD 2019 is displayed in 
the Windows Start > All Apps. 

A HyDraw CAD 2019 shortcut icon is created on the desktop. 

 
HyDraw CAD Installation screen 

 
HyDraw CAD 2019 desktop icon 
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3. Usage Authorization 

HyDraw® CAD 2019 could be authorized with Standalone License or Network License based on the purchase. The Program could be evaluated using 30 days Trial Period. 
 

1. Submit Standalone Authorization Request 

1. Double click the HyDraw® CAD 2019 desktop icon. 

The HyDraw CAD 2019 Authorization dialog box displays. 
 

 

2. Select Authorize HyDraw CAD 2019.  

3. Click Next. 

4. Enter the Serial Number provided when you purchased the software.     

 

5. Click Next. 

6. Enter your contact details. 

 

7. Click Create Request. 

Authorization request is generated and prompts to save in an xml file. 

 

8. Attach the request file to an email and send it to support@VESTusa.com. 

9. Click Close. 

mailto:support@VESTusa.com
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2. Authorize Standalone License 

1. Double click the HyDraw® CAD 2019 desktop icon. 

If the program is not authorized, then the License Server Product Authorization 
dialog box displays. 

 

 

2. Select Authorize HyDraw CAD 2019. 

3. Click Next. 

The HyDraw CAD 2019 Authorization dialog box displays. 

4. Select Open authorization file. 

 

5. Click Browse and select the saved Authorization code XML file. 

 

6. Click Activate. 

Confirmation message displays: Your HyDraw Installation has been authorized 
Successfully. 

 

7. Click Close. 

The dialog box closes, and HyDraw License is successfully activated. 

Note: 

For checking HyDraw License Details, refer Ch77. 
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3. Use and Borrow Network License 

The HyDraw® client machines can use a network license available from the HyDraw License Server Manager. 

Using Network License 

1. Double click the HyDraw® CAD 2019 desktop icon. 

The HyDraw CAD 2019 Authorization dialog box displays. 

 

2. Select the Network license option. 

3. Click Next. 

4. Set the License Server Name/IP Address and Port number. 

 

5. Click Apply. 

Borrowing Network License 

6. Select the Borrow until date. 

 

7. Click the Borrow button. 

The Borrowed license details are displayed in the grid. 

8. Click  Close to exit. 

 
 
Note: 

For checking HyDraw License Details, refer Ch77. 
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4. Migrate Settings 

Migrate the HyDraw® settings of old version to HyDraw CAD 2019. 

1. Select,  Start  
   > All Apps  
       > HyDraw CAD 2019 
          > Migrate HyDraw CAD 2019 Settings 
 
The Migrate HyDraw Settings message box displays. 

 

2.   Click Yes to migrate old version of HyDraw settings to 
HyDraw CAD 2019 settings. 

 
 

Note:  

Migrate settings will override the existing settings. 

 

 

 
Migrate Settings 

 

 
Migrate Settings Message Box 
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5. Export Settings 

Export the existing HyDraw® settings. 
 

1. Select, Start  
   > All Apps   
      > HyDraw CAD 2019 
         > Export HyDraw CAD 2019 Settings 

The Export HyDraw Settings message box displays. 

2. Click Ok to open the Browse folder. 

3. Select the folder where you want to export all the 
HyDraw Settings files. 

4. Click OK to save and exit. 

 

 

 
Export Settings 

 

 

 

Export Settings Message Box 
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6. Import Settings 

          Import the HyDraw® settings to the existing HyDraw settings. 
 

1. Select, Start  
   > All Apps  
      > HyDraw CAD 2019 
         > Import HyDraw CAD 2019 Settings 

The Import HyDraw Settings message box displays. 

8. Click Yes. 

The File Select dialog box displays. 

9. Select the HyDraw settings zip file to import. 

10. Click OK to exit. 

 

 

 
Import Settings 

 
 

 
Import HyDraw Settings Message box 
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80. Library Network Configuration 
HyDraw® CAD 2019 can access data from the HyDraw library on a local network. 
This enables all designers in an organization to work efficiently by sharing a common data resource.   
For details on installing the HyDraw Library, refer the Library Manager User Manual.  
 

Library Network Configuration 

1. Select Circuit > Options from the HyDraw CAD 2019 ribbon 
menu. 

The HyDraw Options dialog box displays. 

2. Select the Library Path tab.  

3. Select the Corporate Library option. 

4. Select Enable modification, if you want to modify your 
library. 

5. Click Browse… 

6. Navigate to the folder, where your HyDraw Library data is 
installed.  

7. Repeat step 2, 3, and 4 for each of the specified HyDraw 
data paths. 

8. Click OK. 

All HyDraw Library paths are configured as selected. 

 
Note: 

All data paths shown are default. 
You can configure to common network data paths. 

 
HyDraw CAD library default paths 
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81. Set Online Services (FPT) 
Internet Settings for accessing FluidPowerTools.com 

1. Automatically detect settings 

 

If your computer is connected to the Internet through a direct 
LAN connection, then select the Automatically detect settings 
option. 

 
Connection Settings – Direct Connection 
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1. Proxy Connection 

If your computer is connected to the Internet through a web 
proxy server, then select Use proxy server. 
 

Configure the proxy settings. 

1. Enter the address. 

2. Enter the port number. 

3. Enter authentication details, if required. 

 
You may refer to the settings that may be already defined 
in your web browser. 

 
 
Note: 

• If an automatic configuration script is used in the browser 
for proxy, then use the Proxy server settings from the LAN 
Settings dialog box in the browser to configure your Proxy 
Connection settings. 

• If you do not find proxy server details in the browser,  
then contact your system administrator. 

 
 

Connection Settings – Proxy Settings 
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82. Build New Symbols 
Create symbols from the building elements supplied along with the library. 

  

In the HyDraw® Library Explorer, browse to 
the required folder, where you want to add a 
new symbol. 

1. Click Manage Symbol. 

2. Select Build New symbol from the drop 
down. 

The Build New Symbol window 
displays. 

The basic building block elements 
are structured in logical folders for 
easy access. 

3. Browse to the required folder. 

The Basic Building Elements are 
displayed in the right side window. 

 

 
Manage Symbol - Build New 

 
Build New Symbol –Basic Building Elements 



 

VEST, Inc. HyDraw® CAD 2019 195 

 

 
  

4. Double click or drag and drop the basic 
elements to the drawing space. 

5. Position the elements at the right 
place. 

6. Insert the port names from the Port 
Names folder. 

The Port Name symbol consists of a 
Connection Point and Port Name. 

Once your design is complete, select 
the Add New Symbol to bring the 
newly built symbol into the library. 

 
Basic Building Blocks inserted into the drawing space 
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1. Add New Symbol 

Add newly designed or modified symbol in to the HyDraw® Symbol Library. 

In the HyDraw Library Explorer, browse to 
the required folder, where you want to add a 
new symbol. 

1. Click Manage Symbol. 

2. Select Add New Symbol from the drop 
down. 

The Add Symbol dialog box displays. 

3. Select Application. 

4. Select Component Type. 

5. Click OK. 

6. Select the symbol to add. 

7. Specify the Insertion point. 

8. Press Enter/Tab. 

The symbol is added into the library. 

 

Note: 

You need to revisit the folder to view the 
inserted symbol. 

 

      
 Manage Symbol - Add New Symbol                                                  Add Symbol 

 
The New Symbol is added to HyDraw Library 
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2. Edit Master Symbol 

Modify the master symbol available in the HyDraw® Symbol Library. 

In the HyDraw Library Explorer, browse to the required folder and 
select the symbol to edit. 

1. Click Manage Symbol. 

2. Select Edit Symbol from the drop down. 

The symbol displays on the drawing space along with the 
Edit Master Symbol dialog box. 

3. Edit the symbol. 

 
Edit Master Symbol 

Edit Port 

1. Type the new name in the Name column and the optional 
name in the Other Name column. 

2. To delete the port, click . 

3. Select Name/Other Name in the Display option. 

4. Click OK. 

The Name/Other name of the port displays with the 
symbol, 

If both the names are selected, then dual port names are 
displayed. 

Insert Port 

1. Type the new name in the Name column and the optional 
name in the Other Name column. 

2. Click Insert and insert the port on the symbol. 

3. Specify the port insertion point. 

The Edit Master Symbol dialog box reappears after the 
port insertion. 

 
Edit Master Symbol 
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Display Formats 

1. Click  to add the new display format. 

2. Click  to rotate right. 

3. Click  to rotate left. 

4. To delete the earlier display format, click . 

 

 

Solenoid Information 

1. Click   to add the new solenoid. 

2. Enter the Solenoid ID and Solenoid Name. 

3. Click  to Update the Solenoid ID and Solenoid Name. 

4. Click  to delete the solenoid from the list. 

5. Click OK. 

The modified symbol is updated in the library. 

 
Note 

• You need to revisit the folder to view the changes of the 
modified symbol. 

• Click the Building Blocks to insert the basic building elements 
from the Building Blocks window. 
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3. Delete Symbol 

Delete the master symbol available in the HyDraw® Symbol Library. 
 

In the HyDraw Library Explorer, browse to the required folder 
and select the symbol to delete. 

1. Click Manage Symbol. 

2. Select Delete from the dropdown. 

The Delete Symbol dialog box displays. 

3. Click Yes. 

Symbol is deleted from the library. 

 
Caution: 

The symbol once deleted, is permanently removed from the 
library and cannot be brought back. 

 
Manage Symbol – Delete Symbol 
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83. Build New External Ports 
Create custom external ports from the building elements supplied along with the library. 

1. Add New External Ports 

Add newly designed or modified external ports into the HyDraw® Symbol Library. 

1. In the External Port Library of HyDraw Library Explorer, 
browse to the required folder, where you want to add a 
new symbol. 

2. Click Manage Symbol. 

3. Select Add New from the drop down. 

4. Select the symbol to be inserted. 

5. Specify the Insertion point. 

6. Press Enter/Tab. 

The symbol is inserted into the library. 

 

Note:  

The symbols should have minimum of one connection point. 

        
      Manage Symbol > Add New External Port 
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2. Edit External Port Symbol 

1. In the External Port Library select the symbol to edit. 

2. Click Manage Symbol. 

3. Select Edit from the drop down or Right click and select 
Edit. 

The symbol displays on the drawing space along with the 
Edit Port Master Symbol dialog box. 

4. Edit the symbol. 

 

 
Edit Port Master Symbol 

Edit Port 

1. Type the new name in the Name column. 

2. To delete the port, click . 

3. Select Name in the Display option. 

4. Click OK. 

The Name of the port displays with the symbol. 

 

Insert Port 

1. Type the new name in the Name column. 

2. Click Insert and insert the port on the symbol. 

3. Specify the port insertion point. 

The Edit Port Master Symbol dialog box reappears after 
the port insertion.  

 
Edit Port Master Symbol dialog box 
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Display Formats 

1. Click  to add the new display format. 

2. Click  to rotate right. 

3. Click  to rotate left. 

4. To delete the earlier display format, click . 

 

 

 
 
 
 

3. Delete Symbol 

Delete the master symbol available in the HyDraw® Symbol Library. 
 

1. Click Manage Symbol. 

2. Select Delete from the dropdown. 

The Delete Symbol dialog box displays. 

3. Click Yes. 

The Symbol is deleted from the library. 

 
Caution: 

The symbol once deleted, is permanently removed from the 
library and cannot be brought back. 
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84. Build New Sub-Systems 
Create sub-systems from the building elements supplied along with the library. 

  

In the Sub-System library of HyDraw® Library 
Explorer, browse to the required folder, 
where you want to add a new symbol. 

1. Click Manage Symbol. 

2. Select Build New symbol from the drop 
down. 

The Build New Symbol window displays. 

The basic building block elements are 
structured in logical folders for easy 
access. 

3. Browse to the required folder. 

The Basic Building Elements are 
displayed in the right side window. 

 

 

Manage Symbol - Build New 

 

Build New Symbol –Basic Building Elements 
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4. Double click or drag and drop the basic 
elements to the drawing space. 

5. Position the elements at the right 
place. 

6. Insert the port names from the Port 
Names folder. 

The Port Name symbol consists of a 
Connection Point and Port Name. 

7. Once your design is complete, select 
the Add New Sub-System to bring the 
newly built symbol into the library. 

 
 

 

Basic Building Blocks inserted into the drawing space 
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1. Add New Sub-System 

Add newly designed or modified sub-system in to the HyDraw® Sub-System Library. 

In the Sub-System Library of HyDraw Library 
Explorer, browse to the required folder, 
where you want to add a new sub-system. 

1. Click Manage Symbol. 

2. Select Add New Sub-System from the 
drop down. 

The Add Sub-System dialog box 
displays. 

4. Select Application. 

5. Select Sub-System Type. 

6. Click OK. 

7. Select the sub-system to add. 

8. Specify the Insertion point. 

9. Press Enter/Tab. 

The sub-system is added into the 
library. 

Note: 

You need to revisit the folder to view 
the added sub-system. 

 

      

Manage Symbol - Add New Sub-System                Add Sub-System 

 

10. The New Sub-System is added to HyDraw Library 
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2. Edit Master Sub-System 

Modify the master sub-system available in the HyDraw® Sub-System Library. 

In the Sub-System Library of HyDraw Library Explorer, browse 
to the required folder and select the sub-system to edit. 

1. Click Manage Symbol. 

2. Select Edit Sub-System from the drop down. 

The symbol displays on the drawing space along with the 
Edit Master Symbol dialog box. 

3. Edit the sub-system. 

 

Edit Port 

1. Type the new name in the Name column and the 
optional name in the Other Name column. 

2. To delete the port, click . 

3. Select Name/Other Name in the Display option. 

4. Click OK. 

The Name/Other name of the port displays with the 
symbol, 

If both the names are selected, then dual port names are 
displayed. 

Insert Port 

1. Type the new name in the Name column and the 
optional name in the Other Name column. 

2. Click Insert and insert the port on the symbol. 

3. Specify the port insertion point. 

The Edit Master Sub-System dialog box reappears after the 
port insertion. 

 
Edit Master Sub-System 
 
 

 
Edit Master Sub-System 
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Display Formats 

1. Click  to add the new display format. 

2. Click  to rotate right. 

3. Click  to rotate left. 

4. To delete the earlier display format, click . 

 

 

Note: 

• You need to revisit the folder to view the changes of the 
modified sub-system. 

• Click the Building Blocks to insert the basic building 
elements from the Building Blocks window. 
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3. Delete Sub-System 

Delete Sub-System command enables you to delete the master sub-system available in the HyDraw® Sub-System Library. 

In the Sub-System Library of HyDraw Library Explorer, browse to 
the required folder and select the symbol to delete. 

1. Click Manage Symbol. 

2. Select Delete from the dropdown. 

The Delete Symbol dialog box displays. 

3. Click Yes. 

Sub-System is deleted from the library. 

 
Caution: 

The sub-system once deleted, is permanently removed from the 
library and cannot be brought back. 

 
Manage Symbol – Delete Sub-System 
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85. Manage HyDraw CAD Drawings thro’ Vault 
Manage HyDraw CAD Drawing revisions through Vault. 

Like all other dwg files, HyDraw CAD files can be 
added to Vault, viewed in Vault and opened from 
Vault.  

The Files can be also checked In and checked Out, 
and maintain revisions from the Vault Interface. 

 

Note: 

For more details regarding Vault usage, refer 
Autodesk Vault online knowledge base. 

 

 
Autodesk Vault Professional 2019 
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